[Solved - almost]Footprint supposed to have 3D model but there isn't

This footprint it seems to be linked to a 3D model.
But in fact isn’t there.

So when I edit it trying to link it to a 3D model, I discover that it’s supposed to have it, but for some reason: there is not

Because: if I update it, as soon as I update KiCAD (and I always do via the simplest download link), as I learned in another topic, it will wipe out the old library and I wil lbe back without 3D model for this footprint.
At the same time, I don’t think is the correct way to create a custom footprint, since (from the screenshot) it’s supposed to be already linked with the 3D Model that’s coming with KiCAD itself

What’s wrong please?
To me, it seems that the standard variable is wrong. but then I’m wondering if updating it, will not scr**up everything perhaps in other projects :-/
May I change it without have troubles?

I hereby certify that I am not simply asking someone else to design a footprint for me.

This is an auto-generated message that is in place on the “footprints” section of the KiCad.info forum. If I remove it and ask for a footprint to be designed anyway, I understand that I will be subject to forum members telling me to go design my own footprint or referring me to a 3rd party footprint site.

I’ve noticed that some time ago that there is many footprints linked to non-existent 3D models.

If I remember correctly someone said that it is intentional, so in a future if someone add a 3D model to the official KiCAD library everything else is done.

I don’t agree with this (I’d prefer adding a link to a 3D model after someone actually uploads it), but I’m not a KiCAD developer, so will live with this…

1 Like

I’m going ahead to try to understand why everything doesnt work even changing the local variable … I did it at my risk … but I wnat this problem solved.

And I discovered the name fo the footprint was removed as well.
here the old name:


Here there is not any longer:

I see a SOU in place of a SOP

I discovered some time back that some footprints in the SOP line don’t have models but the corresponding footprint in the SOIC line does. In this case SOP-8_5.28x5.23 has no equivalent but a close specimen SOIC-8_5.275x5.275 which may or may not be a suitable substitute.

1 Like

Ok and after have updated the variale … ta daaaaaaaa lost everything … nice reliability …

Fortunately I didn’t save anything. Closed all (included KiCAD) and reopened, and I’m back to the start :-/

From the FAQ:

[Why a footprint points to a 3D model but the model file doesn't exist?]


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.