Solder Mask Creation Problem

I have created a 2-sided PCB in v5.1.10 and can not satisfy JLCPCB inspectors when it comes to the Solder Mask.

I have tried all the online steps (most are so out of date that menus don’t exist) to create the solder masks and the built-in Help file was of no help.

I can see what “looks” like a solder mask on the top and bottom (red and green) when I used the “Fill Zone” (green square on right side tools), but apparently that is not really a solder mask. And I don’t find anything that specifically mentions Solder Masks in the PCBnew part of the program. I also don’t see anything when I uncheck everything but F.Mask and B.Mask options and those files are just 1K when plotted. I would expect them to be larger as there are over 200 via’s in the project.

I also uploaded my ZIP file to <> to view it and it says it’s unable to render the F or B Solder Masks and are grayed out.

What on earth am I missing to get these created?

First, have you read How does solder mask layer work?

Usually you don’t have to add zones or graphics to the mask layers because the mask openings for pads should already exist in footprints. Do you have some special need?

Yes, I did look at your video a few times, but I’ll go back and give it another look to see what I’m missing. Everything is THP (old school) devices.

I don’t have any footprints as such, just all the via’s as everything is my own design and devices. I tried to use the Footprint Editor, but found it to be a hassle modifying something that was “nearly” what I needed.

I would be more than happy to send you my PCB file to look at, and see if you can point me in the direction I need to go. I’m sure its something that I’m just missing. I have not designed PCB’s in over 35 years, and even then I did them the old way with photo resist boards, dot matrix printed transparencies and lots of lights in my kitchen. For the time, it was cutting edge for me.

Your workflow isn’t really supported by KiCad. To take advantage of basic features you should start with a schematic and attach footprints to symbols. If you use standard THT components you should find them in the official KiCad libraries.

But if you just want to use those vias, you can try to check Do not tent vias in the Plot dialog.

Typically number of vias has nothing to mask file sizes as there are no openings for vias at masks.

1 Like

Look at some videos about the process and try again.
If you don’t manage, get back to us here and tell us what you have problems with and there will be plenty with help (and maybe some sarcasm ;-).
Don’t let that discourage you.

Many on here will tell you that library work (creating symbols + footprints) is 70% of ECAD work.
It sucks and that’s why there is a symbol and footprint library premade already…
But at some point you will need a custom design and learn how to use the sym/fp editors.

Try it again, it’s really not that bad once you got the hang of it.

I fixed the problem. It was with the footprints. JLC has now started the drilling process. Thanks everybody.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.