Routing problems with Kicad 5.1.5


In my project I have problems to route. I can not, but I have try with other project and works.

Is it possible that there is some footprint that is not right and is giving this problem? If it is there how can I find which one?

Or can you make some incorrect settings in my project?

Best regards

With the information provided it is very difficult to provide help. Basic starting information necessary would be what version of KiCad are you using, whether or not you have a schematic and a screenshot of where you are having trouble. It maybe that you have clearance issues - trying to connect too wide a track with too wide clearances to a pad is a common cause of this sort of issue but there are many other reasons why you are having problems. Often it is simplest to post your entire project for review.


Yes John, I understand.

I have done the dist-upgrade of my os, and reinstall kicad and libraries, footprints, etc.

Again I have executed netlist and now works fine.

Thank you and regards.

Sorry, now I have the same problem, is not fixed.

If I update the PCB from the schematic the first time, not problem, but when I save the project the problems appear.

I have created the outline and saved it and now works. I had tried this before the ugrade and the update but it had not worked. Let’s see if it doesn’t appear anymore.

Yes the problem appear again when I hidde the footrpint references and values (Edit Text & Graphic Properties…)

If I use Ctrl+Z the problem disappears.

Could you copy the complete Kicad version that you are using (from the About Kicad menu) and paste it here? Also, can you zoom out your board a bit to show the whole thing.

Application: Pcbnew
Version: 5.1.5+dfsg1-2build1, release build
wxWidgets 3.0.4
libcurl/7.67.0 OpenSSL/1.1.1d zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.20.2 (+libidn2/2.0.5) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3
Platform: Linux 5.4.0-14-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
Boost: 1.67.0
OpenCASCADE Technology: 7.3.0
Curl: 7.66.0
Compiler: GCC 9.2.1 with C++ ABI 1013

Build settings:

You probaply should check out:

your problem is most likely that kicad can’t find a way to place your trace without violating the design rules.

1 Like

You did move the texts to the copper layer. Of course you can’t route through copper texts.

If you want to hide texts for a while so that they don’t bother you when routing, use the Layer Manager -> Items.


If you want to hide the texts so that they have “hidden” property and won’t be plotted to gerbers, use the Edit -> Edit Text etc. dialog.

1 Like

You are in the right, I’m using the copper layer and is the silks layer, now works perfect.

Sorry and thank you.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.