Replicate plugin problem

Hello, I’m new to kicad. I tried the replicate plugin using a simple circuit. I got an error message, u’5EE0313F’. I have scripting = on and wxpython = on. I am using 5.1.4 on a windows 10 64bit computer. Any help is appreciated.thanks!

If you’re new, is there any barrier to using the latest KiCAD version (5.1.6)? KiCAD development is fairly rapid and, unless there’s a significant reason to not to, you should upgrade.

You’ll have to be more specific. Which plugin did you run? How did you run it?

If you’re talking about Replicate layout plugin look into the project folder and search for replicate_layout.log file. Attach it here or as you are a new member paste its contents.

I don’t think you need to upgrade to 5.1.6 just yet

1 Like

Thanks for your reply,

I created a hierarchical sheet and put a simple circuit inside.
Exited the sheet and made a copy of the sheet.
Ran the DRC and then created the netlist
Clicked on the PCB and imported the netlist. I got 2 copies of the circuit.
I arranged the components and added wires on the first circuit.
Then selected a component on the first circuit and selected place footprint.
Here’s the response

Here’s the log.

06-10 14:57:51 replicate_layout.action_replicate_layout 305:Plugin executed on: ‘win32’
06-10 14:57:51 replicate_layout.action_replicate_layout 306:Plugin executed with python version: ‘2.7.15 (default, Oct 11 2018, 12:09:51) [GCC 8.2.0 64 bit (AMD64)]’
06-10 14:57:51 replicate_layout.action_replicate_layout 307:KiCad build version: Unknown
06-10 14:57:51 replicate_layout.action_replicate_layout 308:Replicate layout plugin version: 64 started
06-10 14:57:51 replicate_layout.action_replicate_layout 340:Preparing replicator with D1 as a reference
06-10 14:57:51 replicate_layout.replicatelayout 211:getting project hierarchy from schematics
06-10 14:57:51 replicate_layout.replicatelayout 213:Project hierarchy looks like:
06-10 14:57:51 replicate_layout.replicatelayout 221:getting a list of all footprints on board

Application: Pcbnew
Version: (5.1.4)-1, release build
wxWidgets 3.0.4
libcurl/7.61.1 OpenSSL/1.1.1 (WinSSL) zlib/1.2.11 brotli/1.0.6 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) nghttp2/1.34.0
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.68.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.61.1
Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:

thanks again!

A side note: I wounder if this How to repeat multiple layout blocks? still work on 5.1.4 version :-). If you had a change to try, please let me know.

Again, you need to be precise. In the first post you’ve alluded to Replicate layout plugin. You’ve attached the replicate_layout.log file but the screenshot and your description show that you are running Place footprints action plugin.

Now it is totally possible that you get a crash when running either of the two plugins, but I’d rather cover each case separately

Is it possible that you’ve created schematics, kept the schematics window open, updated pcb from schematics, made the layout and run the plugin and you did not save the schematics? This seem the most likely case, so I’d like you to confirm this. If not, then please go to github page and open a new issue (even better two of them, one for each plugin). You can even attach the .log file and complete kicad project with the reported issue as this will make my job somewhat easier.

Hello Mitja, I started a new project and rebuilt the circuit and now it works! I’m not sure what I did wrong the first time. It’s a very nice plug in. Thanks for your help.

Don’t get me wrong, I appreciate any reported bug, and from the looks of it you’ve encountered two of them. In each case, the plugin should at least fail gracefully with meaningful error message. But it is hard for me to find out why it failed especially if it can not be recreated. So if (when) you encounter a bug, put yourself in OCD pedantic mode if you can and report back any and all details.

The complete text from the popup window with “Exception on python action plugin code” should also be part of that, and that’s not even in CDO (Similar to OCD, but letters in alfabetical order, as they should be) mode.

OK I will try to provide more details.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.