Raytracing BUG in Kicad 6: some 3rd-party models show triangles instead of normal color


I’ve been having issues with raytracing unofficial 3d models in KiCad6.
I’m naming this a bug because it’s not happening in KiCad 5 as you will see in the images down below and because it’s happening with parts created in either FreeCad and Fusion360.

For the purpose of creating the screenshots I assigned the .step model to some random footprint. The 3D model is just an ESP32 devkit module BOARD, just the base black board that is.

Here’s what it looks like in KiCad 5:

And this is in KiCad 6:

I’m also attaching the .step file in case you want to test it yourself:
ESP32_DevKit_V1_DOIT.step (32.7 KB)

I didn’t create this model. But my models created in Fusion360 also have this rendering problem.

You can also try with this GrabCAD model, it also has the rendering glitch: https://grabcad.com/library/smd-4-dip-4-gull-wing-1

However, this one doesn’t have any problems: https://grabcad.com/library/sumida-cdrh74-1
As a matter of fact, I can edit that last model in Fusion360, change its color and it will still render properly.

Here’s a final test with some simple figure I created in FreeCad:

And here’s the step file:
FreecadBody.step (20.7 KB)

What is going on?

Lenovo Legion 5 with RTX3060 running Windows 10.

Thanks in advance

1 Like

Looks like this: 3D viewer : In ray tracing mode, the 3D model is displayed incorrectly (#9835) · Issues · KiCad / KiCad Source Code / kicad · GitLab

1 Like

That’s exactly the same problem, yes.
I tried searching on Gitlab but couldn’t find anything. Strange…

Thanks, I’ll continue there

I have the same problem in V6

Same issue here, on MacOS. I would describe the render issues as zebra triangle faces.
I have attached an image for reference. The 3D model is from GrabCad.

Note: Somehow I can not open the v6 file with a v5 KiCad.

KiCad 3D Viewer, Version: (6.0.1-0), release build
Platform: macOS Big Sur Version 11.6.2 (Build 20G314), 64 bit, Little endian, wxMac

KiCad 6 is a newer file format and is not backwards compatible with 5.

Do you have both .wrl and .stp files active in the model selector window?

I thought so, too. Looks like I can not test the v6 file with v5.

I assigned the model by doubleclicking the footprint in the PCB editor. From the “3D models” tab I added the STEP (.stp, I assume) file. I have no .wrl or .stp file activate option. Different User Interface on different OS? I am on MacOS. Perhaps I am missing something? A clarification would be helpful. Thank you!

Are you having this issue where multiple models are selected?

EDIT i see you mention no wrl files are present. For best results with 3d rendering you might like to look at the FreeCad Step Up work bench which will process models into wrl models which work well with KiCad.

1 Like

Thank you for the tips! My problem has been solved.

I resaved the troubled STEP files in FreeCad as STEP files (the FAQ says WRL are not ideal) and now the renders look fine*: see below. :thinking:

Wish there was a command line option for this in FreeCad.

* I changed one 3D model in the meantime

1 Like

This trick worked for several models, but re-saving from FreeCAD is not working for one basic model that I have. I always like to include a rendered view from KiCAD of my board to the assembler, but this time I will just need to provide the non-raytrace model as it looks better.

FreeCAD view of step:

KiCAD (v6.0.2) non-rendered view:

KiCAD rendered view:

Hi Folks,

This issue should be fixed in the latest builds for 6.0. Please test and report in this issue if you still see problems.

Windows testing builds

MacOS testing builds


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.