Problems with kicad 4.0.5 on Mac OS X 10.11.6



I have some problems using kicad 4.0.5 on Mac OS X 10.11.6

  • There are redrawing issues. Sometimes the “content”-area of a window will not be redrawn, if I resize the window. If I make the window bigger, the content keeps its size and the space until the window-frame is empty. But this is only sometimes and I did not find any pattern until know, when this happens and when not.
  • I am not able to close most of the windows, after I have opend them once. If I klick on the Window-Close-Icon, nothing happens.

Is this normal on a mac? Are there any solutions to fix this issues?

Have a nice day


Sorry for not being helpful, but I run 4.0.5 on my 10.11.6 Mac and I do not see the issues you face. The problems aren’t normal.



Do you have wxwidgets or wxpython installed through brew or similar package manager on your machine?


@xzcvczx yes, I need this for some other apps like gnu-radio


there is a fix somewhere, or the other option is to rename the python folder i think it is in or it might be the wx-3.0-osx_cocoa folder thats in

neither of these is ideal the problem is figuring out the best way to work aorund this issue. As if wxpython isn’t bundled into the bundle its required on to be preinstalled on users systems (not the osx way), but if is removed then if wxwidgets isn’t bundled (due to a slightly different build process) then the wxpython stuff may not be available.

This is a known issue and i myself have spent some time on trying to come up with a universal solution that will work all the time.


I think @xzcvczx posted the following link for a fix!

the bug is marked as status-confirmed, importance-undecided :frowning:

I have had occasional problems with the tool palette disappearing - so far it has only been a transient issue & not been a show stopper so I have ignored it and I too don’t want to give up wxpython as I need it elsewhere. Not tried this patch - would be interested if there is any other feedback.