Problems installing kicad libraries under manjaro linux (arch derivate)

I just installed kicad and things went pretty smooth and then I tried to install libraries…

This is my SW:
Application: KiCad Version: 5.1.5, release build
wxWidgets 3.0.4
libcurl/7.68.0 OpenSSL/1.1.1d zlib/1.2.11 libidn2/2.3.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh2/1.9.0 nghttp2/1.39.2
Platform: Linux 5.4.18-1-MANJARO x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
Boost: 1.71.0
OpenCASCADE Technology: 7.4.0
Curl: 7.67.0
Compiler: GCC 9.2.0 with C++ ABI 1013

As there is no particular package for Manjaro I used the Arch Linux package. That brings me to my first question: Is there any known issue that this does not work 100% - dependencies?

I installed kicad via pacman w/o errors. It opens nicely and I can open projects from the demo folder.
Next I read all I found about adding libraries. In particular I found a nice paper here with suggestions how to arrange a folder tree for libs in the home directory. I did so. And, of course I switched the path in the libmanager.
Within the libmanager window I see .lib and .dcm files, which I can flag on but they will never show up in their designated target folder - no error mesg.
Please send me suggestions how to proceed

Hi Rene,
Thanks for your fast answer. I read this link before I started.

The easiest option is to simply install the library packages.

I tried and failed, kipi does not work for me and I don’t see another installation program besides the libmanager.

Another option is you manually download the libs…


…delete the sym-lib-table…

Works fine but does not help. Default is greyed out as there is no lib coming with the main installation.
I finally choose “empty” to fill it up later.

Another option is to manually add the libs using the library manager…
…Use the browse button to add libs…and add all .lib files you want

I follow this with the exception that my target folders are in the home directory which I think should not hurt. What’s missing is the result = all those .libs in my target folder: ~/kicad/libraries/symbols and known to the main program.

Is there a way to just copy those libs into the folders and (more important) let the main program know where they are? Do you have reliable information that my versions of Linux and Kicad work together?

With that i mean using your operating systems tool for installing software. (apt, dnf, pacman, …)

This only works after successfully installation with the operating system installation software.

There are 4 officially supported Linux distros: Debian, Ubuntu, Fedora and Arch. There are distros who are supported by the community but of course tested to a lesser degree and in most cases you depend on a single volunteer.

Generally: Library management in KiCad version 5

Hi Rene,

thanks for your answer. Sorry to say: It added much to my confusion .

Can you give me a link lets say to a symbols library that I can install with pacman? I sure wonder where those libraries will be placed and how kicad will get this info.

I had successfully installed the main program but with no libs on board, of course. This window suggests that it is the entry to lib installation.

I still hope that is not a showstopper for me… I love my distri and I sure would like to give up Eagle.

Quoting stuff on the forum: Select the text that you want to quote in the original massage and click the “quote” button that appears on the bottom right of that selection.

Use the pacman (or whatever your software installation tool is) search feature and search for anything that starts with KiCad. In dnf i do dnf list kicad* there must be an equivalent to that with pacman. This has nothing to do with KiCad by the way. This is knowledge about how to install software on your system. (You can also do this in the graphical interface of the software installation tool)

A lot of software packages separate data from the program itself. In KiCad this is done because the libs are >1GB and not everyone has the data available to download these.

Maybe it helps if you explain to us how you installed kicad itself. Did you use the command line for that and if so what was the command you used? Did you use a graphical tool and if so what did you tell it to do? Some other way?

In arch the other packages are called kicad-library and kicad-library-3d

And if all else fails then do a manual setup as explained in the how to manage libraries link i already posted above. (download libs then use library manager to point kicad to them)

Hi Rene,

I followed your recommandations and let pacman run a search which returned the library sets for kicad.
Installing these with pacman was no problem and after adjustment of the paths I can add components
in a new .sch. So far I did not look after footprints or 3d.
The library folders were installed in /usr/share/kicad ( where the main program is) which is not where I want them to be but this is not surprising at all. It is importand that I have a running system now and can start fine tuning (such as moving .libs into /home) from here on.

Thanks a lot for your help and consider this issue as solved.

I highly suggest you leave the system libs where they are. They are placed in the system directory to make it harder for users to modify them. This is done such that you can get updates of the lib. If you copy the lib into home and modify it then you are stuck with the current version.

My suggestion would be you create a parallel library structure with your personal modifications and additions. ( Copy an asset into your personal libs before modifying it.)

An alternative could be the use of git but the more you modify the lib the harder it will get to merge in the changes we made.

thats a good point. Even if I do not want to modify existing libs, updates are always welcome.
On the other hand, modifications to existing components will certainly be necessary for field programmable logic but these are generally personal products and as such kept someplace else.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.