Print problem with some drill holes

I would assume no holes in copper layer for drills.

In manufacturing holes are drilled first.

Then copper is etched away.

No need to etch away an already drilled hole.

Actually the contrary.

You want copper to go all the way up to the hole.
Otherwise you would risk broken net.

Apart from the fact that that’s a very very old version of KiCAD (and the first I did use was the 2013 stable), what does your print preview settings look like?
Might also pay to have your render and layer settings from the PCBnew visibles toolbar.

1 Like

Thanks for your reply. This is a one-off board and as such I shall be fabricating it myself and not sending it to a manufacturer.

I am using an old pc using the Vista operating system.
Thanks Kevin

Yes, I understand.
But I don’t see the tool taking that into account.
But then again, I never used kicad until recently and don’t know how it behaved earlier.

But I for one would consider it almost an error if holes where exposed in the gerbers where drill holes are to be.

I assume they where tiny, during the time you had them.

I understand your problem, but have no solution.

1 Like

The latest kicad runs on XP. Vista is no excuse to run ancient versions of it.

1 Like

See attached information at as I couldn’t attach it to this post directly.
Thanks Kevin

I’m not a mod nor the admin of this website … :wink:

I’ll contact them and see if they can link it here.

Hey @kellykev, we can’t operate like this, unfortunately. You should be able to drop images directly into the text entry box. If you cannot do that for some reason, please host it externally on a site like and post the link here (new users cannot post more than 2 links at a time though, so use an album if necessary).

Here’s what new users can do, from the guidelines here


how long do i remain a new user

Check the link and see how to get to the next level - short version: for normal people that are interested in the topic and browse the forums for half an hour it’s no big deal really. Even the level after Basic should be pretty normal.

Looks normal to me, can’t see any problems.
Can you check your ‘Render’ tab in the ‘Visibles’ toolbar on the right hand side and see if there is anything unchecked that has to deal with drills?

I have checked and all the render settings are ticked except RATSNEST. You should be able to see my render settings from the second of the three screenshots already sent.
Thanks Kevin

Ah, sorry. Didn’t see the other pages. Here they are:

Doesn’t seem to follow any obvious system of which it shows and which it doesn’t.
It definitely shows all drill holes for those jumper things.

Can you switch off the layers F.Cu and Eco2 in that print dialog?

I tried turning off both of the layers that you suggested but the result looks the same.
On the printout (third image) the relay and two 1N4001 diodes also have drill holes. However the line of 8 LEDs only have crosshairs instead of pads on the GNDed side and small diamond areas where their other pads should be. I have a previous printout on a page showing all of the drill holes. I did a ERC and tidied some tracks before saving the design and then the drill hole problem appeared.
Hope the above helps.

Just zoomed the layout printout up to 200% and I now can see all of the drill holes! I went back and set the print scale to 0.5 and zoomed to 200% but the same drill hole issue as before.

Hm… so is it just a visualization failure or not
When you print it (either on paper or as pdf output), what do you get?

Yes, printout on page is fine! Sorry for wasting your time.

On a different matter- I created my modules with the values visible and the references invisible. I have multiple instances of the modules in the layout. For the front silkscreen (assembly drawing) I wish to make the references visible and the values invisible. Is there a way of doing this simultaneously for all the instances of a module? I seem to only be able to update one component on the layout at a time even though I updated the relevant module in the editor.
Thanks Kevin