Possible bug in the footprint to 3D .wrl file association to the footprint


I have encountered the following problem.

I have designed a small board, created the pcb and made a .wrl file of it. I got a nice 3D (.wrl) model of it. So I made a symbol to represent it. So far so good. But when I try to associate the 3D model of this little board to the symbol, I can see the 3D .wrl image of it, but when the association takes place, the 3D model does not show in the window. …See the sequence in the following printscreens.

Figure-1 (the source (beginning) of the schematic)

Figure-2 ( component association …looks fine)

Figure-3 (Footprint Editor …shows the symbol look all right))

Figure-4 (3D Association window)

Figure-5 (3D File selection …look great)

Figure-6 (Return to 3D Association windows …no more 3D !!! …and I tried that process many times so see if it was consistent and it is)

Thank you very much for your help in trying to find the solution.



What kicad version are you using?
What operating system?
Where does KISYS3DMOD point to?
Does this apply to you?

1 Like

The problem must be that your 3D model shape has some offset embedded.
When you select the 3D model in the “Select 3D Model” the preview is center the bouding box of the model in the window, but when you apply it to the footprint it will use the 3D offset of the file.

You need to create a model without offset / centered on your footprint.

I don’ t know how did you generated the WRL but you need to be “creative” to figure how to solve your offset.
EDIT: if you are creating the WRL file with KiCad you may need to center the board arround (or in relation to your footprint) to the (0, 0) position in the PCBnew and then export it again.


Hi Mario,

First, thank you for being part of that team that put this great tool in
our hands. You have to be commended.

It does not look like it is an offset problem. I even loaded the .wrl file
in FreeCAD and there is no sign of offset.

The .wrl file was generated using PCBNew (I used the latest built), but I
tried, without much success the 4.0.6 (stable version) as well.

It could be so many things (…I am using Windows 10).

I have included the files with this email. You might want to test and see
if the behavior is the same on other systems (Linux, or other Windows
versions). If you require other files please let me know.

Thank you so much for your help.



AD9851_Waveform_Generator.pro (1.33 KB)

AD9851_Waveform_Generator.sch (1.28 KB)

Rotary_Encoder_MPA.kicad_mod (1.76 KB)

Rotary_Encoder_MPA.wrl (575 KB)

If you turn on the axis cross in freecad via view->toggle axis cross and you will see that you have an offset.

1 Like

you may find this useful


Probably not the issue…

But at the moment, that 3D viewer window shows the bottom of the board when first opened. I have to grab the mouse and rotate the image to see the opposite side of the board.

Have you looked at both sides of the board in that presentation?

1 Like