Plugin manager: issue downloading plugins

But why to him does it work?

No, it didn’t. He’s going to wait a while before trying again.

1 Like

@retiredfeline Correct. One of them worked (Board2pdf AFAIR), the others did not. Obviously @tormyvancool is experiencing the same.

1 Like

Ok however this is occurring since a while. And I have not clue how to make it work. Indeed, as for the link you posted, it’s not the only one plugin :-/
Yes, I do use the manual way to solve the issue, but it’s a temporary way to do …

If nothing changes by tomorrow and no dev jumps in here by chance, I will file an issue.

1 Like

At the moment the freerouter download was very fast here. V6.010 Linux.
Some reasons in your firewall ?

No. One of the plugins installs ok, so no issue with my config.

1 Like

I don’t know why you stick to that /download/ red herring. No it’s not inadvertent, those are correct urls.
You see in screenshot in first topic of this thread, there is a github url without /download/ and it is still not working.
Must be some locality related github server issue, I have no other explanation here.

Ok. I removed my remark.

Here I show on other packages as well …

There is absolutely nothing we can do if Github’s CDN is misbehaving.

Please here I got a feedback from the programmer. He was able to download/install as I shown above.
He uses a “old” version of KiCAD. I do use the 6.0.10
May be an issue with KiCAD?

Hmm, it’s a combination of specifically GitHub’s TLS1.3 stack which seems unique and Windows schannel behavior that cause the socket to act differently than expected. It’s fixed by curl 7.87 CURLE_RECV_ERROR schannel: SEC_E_DECRYPT_FAILURE · Issue #9431 · curl/curl · GitHub

So I’ll end up updating the nightlies to it but the 6.0 branch is kind of stuck


Thanks for following up on that! Just curious: why does 6.0.2 work?

It’s an older curl.

Then I got bothered by people whining about openssl in 6.0.9 needing to be updated due to a CVE that doesn’t impact us (and is only used by python). Said updated bumped a good chunk of our ecosystem of dependencies besides openssl which includes curl.

Ok but is this now solved? Is it forecast a 6.0.11? I didn’t fully understand the conclusion :-/

It will not be in any 6.0.x. Only in 7.0.0rc in the next days (nighltly).

Hm, somehow my freshly built nightly worked. Is that issue limited to win 11 only? I couldn’t tell from github discussion.

It’s a socket read buffer issue under tls1.3 with schannel. It’s more than likely a combination of the stars aligning. Network latency, network adapter driver, bad curl logic that messed up the entire state of the connection. Nothing windows 11 specific and neither is the fix

All downloads are scr**d up

I think the Plugin manager is now useless.