OpenGL canvas Update


#61

OK, now you’ve really lost me:

  1. First of all, I am told it is impossible to convert a *.wrl to *.step, and here you seem to indicate that FreeCad StepUp should be used to perform that function
  1. while here, you seem to suggest that the *.step file has no function within KiCad (and yet, once it is correctly associated, it does appear in the KiCad 3d Viewer)

#62

I think you are implying here that the *.step exporting functions of my $10k worth of Solidworks software pale in comparison to $0 FreeCad with the StepUp add-in? I am not insulted, but that stings me in the wallet!


#63

If this is the case, Would it not be sensible to run some sort of batch-process to disassociate the *.wrl files from their footprints throughout the Libraries that are in the current (nightly) distribution, and switch the association to the corresponding *.step files?


#64

It is possible to go from step to wrl but not the other way round (step includes information that is not included in wrl. This information can not be recreated uniquely from the wrl file.)

i should have been clearer. with “kicad does not support any wrl model” i meant that not all wrl options are supported.
wrl is a quite varied file format. only a subset of it is supported by kicad. The best guarantee is to use the freecad extension kicad-stepup. (This tool includes its own wrl generator that is tailored for what kicad supports.) But there are for sure other ways to achieve the same.

Only if you assign a step file in the footprint. I was under the (wrong) impression that if no wrl file is found kicad automatically checks for a step file with the same name. (sadly that algorithm is only used for the step export.)


#65

So do you think the same for $0 KiCad? :thinking::stuck_out_tongue_winking_eye:


#66

OK, for all those readers who are getting “fried noodles” reading through this Thread, I will summarize here:

  1. Up to and including v4.0.7, KiCad utilized *.wrl files to illustrate the 3d versions of board components
  2. KiCad has always used just one of many “flavours” of *.wrl file-format, and the best way to arrive at the required “flavour” is to use the FreeCad StepUp add-in program.
  3. The currently “Nightly” builds of KiCad (which are ‘beta versions’ of the soon-to-be-released KiCad v5), can ONLY make use of *.step files for illustrating the 3d versions of components, whether that is in the 3d Viewer of the Footprint Editor, or the 3d Viewer of Pcb Layout Editor [nee PcbNew]
  4. At the present time, the ‘nightly distributions’ of the KiCad libraries erroneously prioritize the association of *.wrl format images with the Footprints [NB: I am uncertain as to whether ALL of the Library’s Footprints have 3d images associated with them, or only the majority of those Footprints]
  5. In the recent past, there was a way to toggle between KiCad’s priorities when associating Footprints with either a *.wrl file, or a *.step file. That toggle no longer exists.
  6. Currently, KiCad nightly / v5 will NOT automatically search for and automatically re-associate [i.e., substitute] a *.step image to a Footprint in lieu of the *.wrl file that is already associated with that Footprint

#67

Current nightly can make use of step. It still can make use of wrl. (What is used is decided by what is assigned in the footprint)

It is not erroneously. It is on purpose as the kicad internal 3d viewer is one of these “marketing” tools i talked about. Rendering results are just better looking with wrl. (step looks bland as it is missing material properties.)

I am not so sure about that. I know that in the past there was some option to turn on step support. I doubt that there ever was a global “use wrl instead of step” button

Even better would be that kicad just ignores the file ending in the footprint and tries to first use wrl, if none is found it could try step. (Until today i just assumed this is the case.)


#68

KiCAD supported in basic way only WRL since KiCAD v3… WRL is much lighter and easy to handle/code than STEP.
WRL support has increased a lot thanks to some great developer already on v4, but only v5 added the support for raytracing and later stp format.
That is why the libs started only with wrl. After the ability to convert pcb and models to step with StepUp and FC/OCC, kicad devs decided to add support also to stp format using OCC and this become a feature on v5 (dev) release.


#69

No, no such association by extension.

I purchased Sworks largely because it is what I have used in professional employment and have used it as an independent contractor. So it was driven by expectations of clients for file portability and so forth. They don’t want to pay for my time, then have to deal with file-type conversions (eg. Solidwork’s *.sldprt files are the ones they use directly, not generic *.step, *.iges etc).


#70

That is not my observation. As I thought I made explicit and clear, I have tried to view the Footprint (all by itself & accessed directly from the current ‘nightly’ or ‘v5’ Library), which came from the Library with *.wrl association, and the component is NOT VISIBLE. And, there is no error message flagged by KiCad indicating a problem with the directory (such as “file not found”). So it seems to be finding the *.wrl file, but cannot display it.
In my experience, this behaviour is also true of viewing the footprint within the 3d Viewer of Pcb Layout Editor (formerly “PcbNew”)


#71

I should add that, if I manually edit the “v5” library Footprint using Footprint Editor and include the *.step file, it will, in fact, display the image.


#72

This is probably because your wrl file is not compatible with kicad. (What we tried to tell you all along.)
Try any wrl file from the official lib and you will see that it works with wrl.


#73

As I said, I am referring explicitly to the Footprint files from the current-distribution Library, not ones that I have created myself!
If I had problems with my own Footprints, I could understand that the problem lies at my doorstep. But the reason why I am continuing to talk about this in this Forum is that the problem seems to be WITHIN the current distribution. And, because those of you who are in the Development circle are talking about releasing this as a V5 very soon, and this seems to me to be a significant bug!

Here are images from my experience within Footprint Editor; one can clearly see the *.wrl image that is associated, but it isn’t shown in the Preview window, nor in the Footprint Editor’s 3d Viewer



#74

Why do you suddenly bring in the footprint again?

Just to be clear do you expect every footprint of the official lib having a 3d model already ready? This is not the case. We supply 3d models for some of them but the 3d settings are still pre filled even if there is no wrl file in the library.

(I thought this is the part you already know)


From the conversation i assumed the following:

  • You use a footprint of the oficial lib that has the 3d settings filled out with file ending .wrl
  • There is however no wrl file in the 3dshapes folder so you created your own wrl file using solid works
  • If you tell kicad to use the step file (also created using solid works) you see the model in the 3d viewer but if you use the wrl file you do not see it.

From all this information i would guess that the wrl file is not valid for use in kicad.


#75

Ok from what i see in your screenshot you have an even deeper problem. This is not a footprint from the kicad 5 library.

The clue is in the library name. As it is a plural it means you have the footprint from kicad 4.

If you have installed nightly however you will have the 3d lib of kicad 5 installed. This does not use plurals in the lib names and a lot of other things in the naming conventions changed. Meaning kicad looks for the wrong model. You need to clean out your kicad 4 libs form your fp-lib-table if you want to use kicad 5 libs and replace it with the kicad 5 entries


#76

Again, to be clear, nowhere in this entire thread do I talk about *.wrl files that I have created (in any way–directly from a Solidworks *.sldprt model, or by opening somebody else’s *.step file and exporting it as a *.wrl).

I am only talking about *.wrl files that are supposedly part of the “nightly” distribution’s Library.

If the path name points to a file which doesn’t exist, Shouldn’t KiCad at least flag this as an error rather than blithely carrying on? Is the KiCad user supposed to check the directory (i.e., packages3d) when choosing each and every component, to be sure that a silent error doesn’t occur?


#77

That’s a very reasonable wish. It’s not long time ago when I didn’t care to download and install 3d libraries for the nightlies. KiCad complained about missing 3d files at some point when loading a board or libraries, I don’t remember exactly anymore.


#78

Yes i remember that kicad complained in the past. It does no longer complain. Neither in the footprint editor nor in the 3d viewer.
It is a bug that it does not complain any more. (And should be reported)


#79

It would be a real pain if an error dialog appears every time a model is missing, so I hope there is an option to suppress the error. Although I don’t recall KiCad ever generating an error for this.

Because it is easy to see that a model is not displayed, does it really need an error? Now, an error for invalid files would be more useful.


#80

Hello, Rene:
Interesting. I have taken the time below to share the details of my installation experience, as it might help someone diagnose a problem with the un-install / install functions.
I am particularly interested in hearing your comments on my point #5, below.
^^^^^^^^^^^^

  1. That is odd, because I did an “uninstall” of KiCad v4.0.7 and (erroneously?) thought that the directories that were created during the installation of KiCadv4.0.7 would’ve been wiped out during the Un-install. The clean-out of those directories created during the Installation is the usual case, I have found, when using the Uninstall function for any software.

  2. Note also that I took the additonal steps of shutting down after the un-install, re-starting and running diagnostic software to clear out temporary files & to clean-up the Registry and so forth, and also de-fragmented the hard-drive prior to shutting down, re-starting and only then installing the “nightly build” (a.k.a. v5). This was in the hopes of avoiding any dangling file associations via the registry etc.

  3. When I installed the ‘v5’, I chose the option to let the software set up my Environmental Variables. So, supposedly, these were correctly set to point only to the NEW directories.

  4. I did not receive any error messages during the Installation process, which would’ve indicated that there were pre-existing directories on the same path and with the same name, which might’ve led to such a problem.

  5. Also, I should point out, that my packages3d directory contains pairs of *.wrl and *.step files. (mostly pairs ---- I cannot be sure that they are all paired as I have not trolled through the directory exhaustively). It was my understanding from all of these postings that the existance of ANY *.step files would’ve been diagnostic of only the new (v5) installation, as v4 could not make use of any *.step files.