One symbol not in list (CvPcb)

I created a circuit with one own component and created a footprint for it. But in the list where assoziate components to footprints ist is not shown.

I’m assuming you are talking about cvpcb (or whatever it’s called these days).

Play with the filter buttons on the toolbar, your filtering is likely overly restrictive.

I assume your footprint is in a custom lib of yours. Did you add it to the library table? Creating a new footprint library

There are many ways to assign footprints. If you use the assign footprints tool then you need to check the filter settings as @qu1ck already pointed out. More on that here: How can i assign a footprint to a symbol?


And maybe also of help the Tutorial: How to make a footprint (From scratch)?

And also: How does KiCad know which symbol pin represents which pad of the footprint?

It is not only a footprint problem I think. After the annotation my symbol ist numbered but with a # in front. I do not know what the # means, I thought that is a mark that it is an created component. But when I call the assign footprints to schematics the component is missing.
Thank for hints
Rainer

And yes my private libs (component and footprint) are added to the library list

A # in front of the reference marks a symbols as virtual. It will not appear in the bom nor will it get a footprint on the pcb. (and therefore not show in cvpcb)

Is it possible you selected “this is a power symbol” in the symbols properties? (This marks a symbol to show in the add power port dialog and it forces kicad to convert this symbol to be virtual)

You might also be interested in this tutorial in this case Tutorial: How to make a symbol

I’am a step further, I had it marked PS as power supply as it is a DC-DC Step down module. Now I changed to U, deleted in the circuit and recreated ist. In the annotation it has now a number U3 without the # in front but it is still not in the list. Another R I had forgotten a added in the circuit was in the list. Mysterious.
Thanks for help till now
Rainer

Solved I hope. Created the symbol new and it is in the list. Can’t find any differences between first symbol and second.
Rainer

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.