Noob Here - Just starting with KiCad - bom problems - possibly due to my ignorance


#21

The Windows and Linux distributions are packaged differently. Windows is monolithic and Linux isn’t.


#22

I just had another thought - If I remember correctly, I loaded those jst connector parts before I realized that I was working with the autogithub download footprint libraries and therefore a remnant from the version 4 Kicad I installed earlier this year but never got around to learning. Is it possible that that part(s) is now pointing to an invalid or non existent 3dshape in the new 3dshapes that have been installed as a result of the KiCad 5 installation ? Sorry for all this noob foolishess guys - I’m so green I don’t know what I don’t know - haha


#23

This might apply: I had KiCad 4 installed previosly. Now i updated to v5. Now i have some problems with the library setup (Seems to have been already posted above but just in case you missed it.)


#24

Yes, you want to put them somewhere else. Just to be sure, you are referring to the individual library repositories (symbols, footprints, 3d packages, and templates) for 5.0, not the combined repository for 4.0, right?

There are a couple ways to handle this. You can either download the entire repository (as a snapshot) and uncompress the archive where you want and have KISYS3DMOD point to that location. (If you download and/or create your own models either manually from datasheets, or by downloading 3d object files from the manufacturer or vendor, you should put them into your own library folder and create a new path name in the KiCad Configure Paths... menu item. I would suggest using a path substitution name of ALT3DMOD for future compatibility with the StepUp plugin of FreeCAD should you want to tweak downloaded 3d objects (usually positioning and sometimes scaling, sometimes painting colors).)

Or get set up with GitHub and download the repository that way so when there are changes to the repository (usually several updates each week) you can avoid downloading the entire repository. Git will download only the changes for you. This is the solution that I use, but I’m not versed in Git well enough to provide much support. (I got it working, hopefully correctly…)

As far as the location to save the repository, it needs to be in a location that doesn’t need administrator access to save files to. This can be in your Documents, on a 2nd data partition or drive, or in C:\Users\Public\Public Documents. The public documents is a special Windows feature that allows all users of the computer to access the files.

That said, the libraries in the 5.0.2 distribution are only a couple weeks old compared to the github libraries…

(@Rene_Poschl, please confirm that my assumption that a snapshot of the github libraries was taken when the Windows 5.0.2 package was built instead of using the snapshot from when 5.0.0 was released.)


#25

Guys - thanks a million for all your help here - and thanks for your patience ! I am going to have a long read of these links you’ve supplied. It’s noon here in my part of Canada and I just realized it and my wife is waiting at her work for me to pick her up…I am going to get a blast from her when I arrive there late…hahaha. But I will tell her I was late for a good reason - learning to set up KiCad ! I’ll be back later.
Thanks again,
Lewis


#26

That is a distinct possibility. The FAQ item that I linked to way up and that Rene just linked to has a link to a post I made with a procedure that I developed for myself for updating legacy projects to 5.0. See step 12 in my procedure, the one that starts with Update the footprints in on your board. That should (among other things) reset the pointer for the 3d objects to the 5.0 approved path/filename. Note, you may still need to start the updating at the schematic level so link to the footprint library is the correct one… :wink:


#27

Back again !

ok - I have tried out a quick “test” to confirm my suspicions and it seems that what I was thinking might be the case, is in fact what is going on. I placed a new connector symbol on my little schematic, then cvpcb’d it with a jst footprint, then created a netlist. I then went to pcbnew and loaded the netlist, placed the new jst footprint (which looked a bit different than the others but I may have selected another variation…not sure) on the board layout. Then I went to view 3d of the board and sure enough - the connector is there on the board and the others are not.

Careful looking at the 3dshape reference when I click on the pcb footprints reveals a footprint that I can’t seem to find in the library. SO… It appears that before I realized I was using the github plugin for version 4 in the fp-lib-table, I had placed the jst connectors on the board. Then, when I cleansed the /roaming/kicad stuff and got a “true” 5.0 installation, these footprints were then pointing to a non existent 3dshapes location.

This little board, while something I am going to make eventually, is not big - I will probably just nuke the jst connectors - and the few TO-220s that are in there too that don’t seem to show up, and bring in new symbols and regenerate the cvpcb and netlist etc. again. In summary then, I think we’ve solved it - and I’ve learned some new stuff in the process thanks to the feedback I got here.

The comments given on the location for the new 3dshapes instead of the one set up by the initial installation of Kicad, has me wondering - when I get to the point of having a different location for them, and then d/l or github sync’ing them, can I just delete all the 3dshapes that are in the location where they were put when I installed KiCad 5 ? i.e the location C:\Program Files\KiCad\share\kicad\modules\packages3d Or will this “break” the installer as was mentioned earlier? Seems an awful waste of space if I have to leave all these obsoleted 3dshapes in there. For the moment, I won’t be doing any of this if this little board I am working on has all the stuff I need from the initial install 3dshapes, but eventually I’ll bring down a fresh load. I want to read the docs more and get the eeschema/pcb layout stuff under my belt more first.


#28

My suggestion:

  1. Uninstall KiCad, and delete your Roaming\kicad dir.
  2. Install KiCad but not in Program Files dir but in any created by you.
    I am doing that way since with first installation of 4.0.6 I noticed Windows knows better then me what I need to do and what not (I couldn’t modify kicad.pro).
    From what you and others write it looks (I/m not sure) the Windows can be the source of problems.
    As I have written previously I have installed 5.0, then 5.0.1 and then 5.0.2 in my Programy dir and noticed no problem with 3d except that for some parts KiCad don’t have 3d yet.
    I have never had anything to do with github. When I installed 4.0.6 and before first run I looked through its files and noticed that there is fp-lib-table and also fp-lib-table.pretty. I looked inside and found that this second one is the same except it points to files on local disc and not to external world. As since 2 years I work on PC disconnected form internet I was looking if I can use KiCad without connection so it was just for me. I renamed thet files and run KiCad with no problem on my isolated PC. V 5.0.2 is configured by default to work locally. But if you had something left from 4.0.7 may be some informations propagated to your schematic or pcb files, and even you removed ewerything form your Roaming\kicad there still are some connections left.

#29

My comments apply only to the Windows installation. I don’t know if any of this will apply to other target OSes as I’m not familiar with how they are packaged together nor the installation process.

I’m not sure. But what you could do is d/l or github sync all 3 libraries (schematic, footprint, and 3d objects) and then either uninstall and reinstall KiCad, or simply install over the existing KiCad and turn off the installation options for the libraries. I’m not sure which will do the desired effect because I don’t know how much cleanup the installer will do if installing without libraries over an existing installation that has libraries. Unfortunately, I think the 3d library will be installed with the footprint libraries, no way to turn just that off.

The complexity with updating the footprint and symbol libraries is there may be new libraries added and one would have to manually reconcile the additions to the library tables from the git repository vs. the ones in AppData. (A simple copy would work only if you never create your own libraries and add them to the global library tables. If you only ever add your custom libraries to the project specific tables it might work, but then you will have to copy tables from project to project.) Also, once 5.1 is released and the target becomes 6.0, I don’t know if the librarians will start trying to optimize the organization again.

Oh, one clarification. As far as the option to sync with github for the libraries, I’m not talking about using the github plugin like 4.x used. I’m talking about using Git (either command line or the GitHub Desktop app) to clone the repository. And then using Git to periodically (or occasionally) update the local to the online. KiCad will think all the libraries are local.


#30

SembazuruCDE, is it possible to update my linux 64-bit KiCAD libraries from the git repository using a simple ftp ? Or is the GitHub Desktop app needed in order to organize the modified files into folders on my computer where the kiCAD applications expect them to be?


#31

I honestly couldn’t tell you about ftp. You don’t need GitHub Desktop, you can use plain vanilla git command line. Now, I know it can be done, but I don’t know well enough to describe how to do it.


#32

Screenshot%20from%202018-12-18%2017-39-57

  1. Copy that url and run git clone <url>
    OR
  2. Click Download ZIP

#33

KiCad is highly flexible in this regard.
You don’t really need to think about where you place your libs. The only thing needed is to give kicad a pointer to it.

I wrote a detailed tutorial for footprint libs regarding exactly this topic. (Symbol lib behave nearly the same in version 5) How can i install a specific version of the footprint library?


#34

Piotr -
I’ve done “half” of this so far - deleting the roaming\kicad dir. But I don’t seem to have the problems you have with the project settings not being able to be saved… Still, I may do the reinstall anyway when I get back to this. KiCad seems to be quite flexible as others have pointed out, so I’m sure there will be a workable solution to all this eventually.
Thanks for your help !
Lewis


#35

I think I am sorted out on all this now. But I’ve now bumbled my way into github for the windows desktop and setting up the KiCad libraries locally that I can “refresh” from time to time. I have started another thread on that with a few basic questions as it’s not really the same topic I started here way back - even though it verred off onto a general noob-kicad setup process ! Thanks again for all the help.
Lewis