No footprint assigned

I am new to this and have managed to make some PCB’s.

I have tried to create a new symbol which looked Ok. I then added it to a schematic and it seemed to connect OK but when i try to make the pcb layout It says ‘cant add DS1 no footprint assigned’…

The properties of the symbol I have created and the footprint I made seems to be attached?

I known this is probably a basic error but I just cat see it…


If I try to update the PCB I get…

Only the relevant part of the schematic is shown. Ignore labels for now…

You might want to read: How can i assign a footprint to a symbol? (TlDr: the footprint field holds the library and footprint pointers)

The ERC error s are kind of self explanatory. You can not connect two pins of type output (what if one output is high one is low? -> Shorts your supply lines) And you need to place the no connect flag (right toolbar the blue X) on pins that are not connected to suppress the not connected warning.
Also ErrType(3): Pin connected to some others pins but no pin to drive it

So to me it seems that you are showing a screenshot of the Dialogue with DS whilst your import error lists DS1.
Have a look at the Topbar in eeschema and locate this symbol in the middle of the pic:
It describes itself as “Assign Footprints to schematic symbols”. When you click it a mask will open with all your symbols and assigned footprints.
If there are no empty ones, you might want to check if Kicad can find your footprint.
The DRC error you show comes from your Symbol configuration, you have a output connected to an output…the DRC does not like that.

Appreciate the pointer and some of it has helped…

Is there a right and wrong place to put new symbols and footprints. Do any libraries I create have to be in a specific place?

Thanks again

Do not place personal symbols into system libs (will get overwritten on update or prevent you from updating)

Generally you can place your libs anywhere on the file system. KiCad does not care. But you might care. (If you make a good organization scheme now then future you will not be frustrated.)

1 Like

So I started again.

I made a new symbol.
I made a new footprint and in the schematic editor I assigned the footprint to the symbol.

When I try to build the PCB it recognises the footprint but cant seem to recognise the pad and therefore wont build the link as laid out in the schematic.

Is there something wrong with the pad definition?

The error i get is;

Error: DS1 pad ~ not found in 13306oled:13306oled. for all 11 pins.

Probably, it has no net assigned. Post the pad properties from the footprint editor, not the PCB. Also, post the pin properties from the symbol.


However, the fact that your footprint is listed as having the reference REF** makes me suspicious that you did not get that footprint in the layout via the update pcb from schematic tool but added it yourself. (The reference here should match the one in the schematic)

The workflow in KiCad is:

  1. Make schematic consisting of symbols, wires and labels
  2. Annotate the symbols in the schematic
  3. Run the electrical rule checker
  4. Assign footprints to symbols that do not have a footprint assigned in the library
  5. Switch to pcbnew and use the update pcb from schematic tool (F8)
  6. Lay out your board using the footprints and connectivity information that you get from the schematic import. (Traces, vias and zones are then used to fulfil this connectivity information)
  7. Run design rule check
  8. Generate manufacturing output data

Some of these can be done multiple times (you can change the schematic after having already started with the layout. You still need to go through steps 2 to 5 after every change)

My previous post was the footprint pad properties from the editor (not the PCB).

Pin properties from schematic is;

“Pin number” needs to be set to the pad number in the footprint, in this case “1” I guess.

Setting it to “~” means “this pin does not have a pad”.

1 Like

I think I have worked it out. I didnt label the pins in the symbol editor.

Thanks guys

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.