No components on board images (3D view)

How was KiCon? Would have liked to go, but I’ve just started a new job after years of unemployment and minimum wage.

Using v5.1.2 Release Build on windoze 10.

When I view the board in 3d, it has no components. Doesn’t surprise me for footprints I made, but for parts from the KiCad libraries like 0603 capacitors and the like…

Hmm. I made some screen shots but don’t find a way to include pictures.

Anyhow, I saw something about not having the 3d libraries, so I used the “Add 3d Shapes Library Wizard.”

The path is already set to C:\Program Files\KiCad\share\kicad\modules\packages3d\ and it warns me that it can’t write there. When I look in that folder, I find 80 folders, each with jillions (a scientific unit) of .step and .wrl files.

When you reply there is an upload button. Seventh from the left. That does the trick.

When you’re opening the Footprint editor and go for the Footprint Properties dialog… there is a tab there, ‘3D Settings’.
If 3D models are on your system and accessible to KiCAD, it will show a 3D view of the part there.

Drag and drop usually does the trick.

Is it possible you upadated from v4 to v5 without taking care of your libraries? (Asking because i remember you from some time back where v4 was the current version and assume you are now on v5) I had KiCad 4 installed previosly. Now i updated to v5. Now i have some problems with the library setup

This hasn’t been mentioned yet, but make sure that in the 3D viewer that you have 3D models turned on. You may have turned them off for some reason and forgotten about that. (I’ve done that before…)


This might not be the reason, but it is something quick and easy to check.

3 Likes

Rene: I installed v5 on a fresh computer, out of necessity as the old computer got etchant spilled all over it and passed away after a few minutes of agony. I kept my one library of odd parts, but I’m using all the new libraries.

Joan: Oh. I see. Of course, not for footprints I made myself, but I thought I used library footprints… Yes, there are the pictures for the footprints for the resistors and the like.

SembazuruCDE: I found that and have all those checked.

Check the footprints themsevles. What 3d model do they reference? Does that file exist?

For info about how 3d models are assigned see: Tutorial: How to make a footprint in KiCad 5.1.x (From scratch)? (last section of this tutorial. The link should point directly to it)

So you see the 3D models in the footprint editor?

PS: please distinguish between pictures (flat, 2D representation of something) and 3D models. If you can see 3D models on your screen, then you see 3D models. But the screen is providing you a picture of them.
Right now we need to find out why your PCBnew 3D view doesn’t show you a picture of the 3D models.
If you’re using 3D model and picture interchangeably, we all will be very confused.

1 Like

Oh. Here we go. Another board I did about the same time has 3d models of some parts.

TrainDetector

Perhaps it’s because I started the other board with KiCad 4. It was about this time that my late lamented Acer died a gruesome death.

The Tiny4313 does not have a 3d model because I didn’t know which 20 pin footprint to use. These are really wide, so I made one from the avr datasheet. I’ve sometimes had trouble with the footprint not being wide enough for the part.

I don’t have a 3d model for a counterfeit NRF24L01+ module. Perhaps not a good place to start learning

I like how KiCad 5 knows the footprint for some parts if you use them from the library. I’ll need more practice. :footprints:

A post was merged into an existing topic: 3D shape position moved between update from 5.1.0 to 5.1.2

Well, what do you know:

I started a new board, put an xMega32E5 and a ATTiny4313 from the library and here’s the picture!!

Love how it knew what footprint to use from the part number. That should save some hair pulling. :footprints:

2 Likes

7 posts were split to a new topic: 3D shape defintion moved between update from 5.1.0 to 5.1.2

If you right click a footprint in PCBnew and then go to this:

You can check under the 3D Settings tab if that footprint has got a 3D shape + path defined and adjust accordingly…

Probably :wink:
But above is a way to go through all footprints and ‘repair’ the 3D shape links, if you’re determined.

Be aware that only ‘repairs’ this board, not the others you have.
That’s why the librarians are as thorough as possible to link footprints with 3D models, when they create/script the libs, so that you have less work.
Alternatively you can go through the libraries and check if the footprints have models attached and thtat they work.
But make sure you save that footprint outside of the standard lib folder, as otherwise this modification could be overwritten when you update.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.