Missing 3D models after new 5.1.10 install

Your OS is?
If Windows, which installer did you use?

I’m on Windows 10. I downloaded “kicad-5.1.10_1-x86_64.exe” from .

What do you have in Preferences - Configure Paths - KISYS3DMOD?
2021-07-28 10_46_23-KiCad

Hi David,

I have the same:


Regards, Dave.

Does the packages3d directory exist, about 5 GB and 12k files in it?

Did you install as your normal username, not as Admin, which causes permissions errors?

It all appears to be there. I didn’t install as administrator. Here are my permissions which are a subset of the Administrators group permissions:



Have you read Why a footprint points to a 3D model but the model file doesn't exist? ?

Thanks. I just did but it didn’t help. picture1 below shows a 3D view on my old computer.

picture2 is a 3D view of the same PCB on my new computer.

This board didn’t have any samacsys parts.

You have only through hole components there, and there’s a setting in the 3D viewer to hide THT components. Maybe that setting is active?

Thanks for the suggestion but “Show 3D through hole models” is checked:


Here’s a 3D view of a board I’m working on now. The samacsys downloaded models are visible:

Do you by any chance have V4 (I don’t know if that is the proper reference to them) 3D model libraries installed on old computer? Note that if you started with KiCad V4, and then upgraded to V5 on old computer, there are most likely V4 3D model available and the footprints are most likely referencing them.

By installing V5 you got only V5 3D model library (which is better in my opinion as it includes .step models beside VRML models).

Asset (symbols, footprints, 3Dmodels, pspice models, templates, …) management is an issue with all EDA tools and you’ll have to find a workflow that best suits you.

As for the specific PCB. One solution would be to install 5.1.10 on old computer and also Archive project action plugin. Then run the plugin on the board to copy and reference the 3D models into the project folder. Then you should be able to open the PCB also on other computers with 3D view properly.

You might want to consider migrating the 3D model library from old computer to new computer. But I’d recommend investigating the current state of your libraries first.

Open one footprint which should have a model but doesn’t show it, open the Properties and show what’s in the 3D Settings tab.

I’ve found the problem when I tried to update some footprints in my current design and got errors.

For some reason, when I did the original installation on my old computer, the global libraries were installed to C:\Kicad whereas in my new installation the environment variables have been used. Too long ago to know why I did that.

The library names have changed as well. In my old installation they were

Capacitors_THT and Resistors_THT

and in the new installation they’re

Capacitor_THT and Resistor_THT.

Those names were used in v4 libraries.

Be really carefull before you’ll proceed. Not only have the library names changed (plural->singular, housings->package) also the asset names have changed.

Take a thorough look at the current (old computer) system that you have what libraries do you have and use. Try to find out what was the source of those libraries. You can always ask here, someone is bound to enjoy some detective work. And when you’ll be sure what libraries you have currently, then think about what libraries you want to have in the future. Once you know what you want, then you’ll have to figure out the migration procedure.

This all sounds hard (and it is) but it is not technically hard. There is no rocket science with solving partial differential equations involved, it is mostly copy-pasting. But you should think about the process.

And you fit more or less in two different categories:

  1. You manage your own libraries and any assets you get from the web you put them in your own libraries (based upon this thread, you are unlikely in this category). The migration should not be a problem

  2. You used the libraries supplied by KiCad. If you started with KiCad V4 and you use V4 libraries (even with V5 version of KiCad) then you have 2 options:

    • You can use the V4 libraries in the future, but you’ll have to manage them on your own (this is a viable option if you do a design here an there, and you are content with the assets available in these libraries)
    • You can migrate to V5 libraries. This can be a PITA and I’d recommend that you finish with currently open projects, and migrate when you have no active projects. But I do recommend the migration. V5 libraries are significantly better than V4. They have more assets, the 3D models include .step models for proper MCAD integration, they follow a known standard (KLC), the naming of assets (mostly footprints) is standardized and makes sense …
      Furthermore V6 libraries will be more or less an evolution of V5 libraries so once you are on V5 libraries, you should be able to migrate to V6 libraries easier.

Thanks very much for this advice. I’m in the first category if you mean that for components with footprints not in the Kicad libraries I either make my own or download them from vendor sites or the web if I can find them.

I’ve moved the PCB I’m working on now to the V5 libraries.

I have quite a few boards using the V4 libraries. One is large with a lot of components.

I’ve been seriously considering converting my old computer to a virtual machine and this adds one more reason. That way I could leave the V4 libraries in place and manage all those boards there and not have to worry about migration. The smaller ones I can migrate if mods are required.


this does not exactly fit your problem but it is another mysterious effect with missing 3Ds:

I extracted KiCad 5.1.10 on a network drive for WIN10.
I set all paths manually to the correct directories on the network drive.
Everything worked fine - except the 3D Models did never show.
I checked the directories, the 3D models were in the right place.

Only when I did the same as above on a local drive the 3Ds showed up !

I do not have access to a WIN10 where I could use the normal .EXE installation but maybe you will see a similar behaviour when you install on a virtual machine ?

Hi all,
I have the same problem.
When I changed from .step to .wrl models where visible again. I think that the 3D viewer do not recognice .step files in these never versions.
Application: KiCad
Version: 5.1.10-88a1d61d58~89~ubuntu20.04.1, release build
wxWidgets 3.0.4
libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3
Platform: Linux 5.4.0-81-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
Boost: 1.71.0
Curl: 7.68.0
Compiler: GCC 9.3.0 with C++ ABI 1013
Build settings:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.