Libraries not loaded

I just installed kicad but can’t get all the libraries to show up in the choose symbol dialog.
Only 4xxx and 4xxx_IEEE show up. How to add all the remaining libs?

What is your kicad version (help->about->copy version info)?
What is your operating system?
Had you any other version of kicad installed in the past?

In the FAQ part there are some insightfull articles about library problems and how to solve them.
A common source of problems is when KiCad V5 gets mixed up with the libraries from KiCad V4.

I’m using version 5. First install, never used before. I think what happened was the libraries
did not install. The download hungup and I canceled the download but Kicad did install. I
launched Kicad and a dialog box opened forcing me to choose library directory, but I didn’t
know what it was. Well, I couldn’t cancel that dialog gracefully, had to force quit the entire program. I later succeeded in downloading the libraries but couldn’t get Kicad to use them
except for two of them. I read something about *.pro and opened that and all of the libraries
are there. But how to get Kicad to load them for my projects? I even tried to reinstall everything but for some reason the package manager (synaptic) doesn’t download and reinstall. It just seems to use the already installed files and config files, even though I did a
“complete removal”. I’m using Mint linux 18.3
Thanks for any tips,

Well if your library setup failed then everything is explained. You will simply not have any local libs or at least some of them missing. (being patient is a help sometimes.) And by canceling the library setup you now have some undetermined state for the library tables. (This is not solved by reinstalling kicad as the installers do not touch your personal settings at all.)

The best course of action might now be to either try and reinstall the library packages or download the libraries directly from git.
In any case you would either need to manually add the libs to the library tables or reset your kicad config directory.

Library management in KiCad version 5 might be a good read. (It explains how to setup the kicad library system properly and he appendix explains how you could get to the official libraries other than relying on the installer.)

I installed KiCad 5 (under Linux) but there are no libraries. (The default option for sym lib table setup is disabled) also explains what to do when the libraries where not installed originally (the mechanism for why they are not installed is different in your case but the resulting system state is the same. Meaning the same solution can be used.)


I specifically asked for the full version info as reported by the dialog i explained above. You are now the 5th person this week who is simply not able to follow such a simple instruction. I slowly loose the will to live to be honest.


So likely, the part of the install archive that has the majority of the libraries didn’t download. You installed a partial package. Try re-downloading and installing. Make sure the download completes fully before installing.

I read parts of this and deleted two files in ~/.config/kicad/ and then started kicad again
it opened a dialog box and I accepted the default directory locations and all the libs are
showing up for my project. Dang! reading the manual works! Thanks for pointing me to
this information. I’m up and running!
thanks again,

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.