Lesson in drawing schematics grinds to halt

The “Active Layer” (whether Edge.Cuts, or another layer) can be selected either in the “Layers” panel on the right side of the display window, or with the layer selection tool in the top ribbon bar.


1 Like

Arrrrgh! :tired_face: It was there! Hiding in plain sight as usual! :unamused:

Good news. It would appear that this build (the third attempt) has been successful.

It is slightly different to the design in the text but that is because I selected Horizontal Footprints for the Resistors, not Vertical ones. My thanks to all who have helped.

One last question (I hope, … in this thread). If I was going to etch this PCB myself I would need two prints of the layout (both of them in mirror view), one of the top of the board, the other of the bottom. My proposed technique involves having the layout printed in reverse, placing the print face down on the board and using a hot iron to transfer the image to the copper.

How do I get these prints?

From the drop-down “File” menu, select “Plot”. In the dialog box you will probably want “PDF” for file type, and the “Mirrored Plot” option. (And don’t be afraid to experiment with the other options, until you get a feel for what they do.)

Get out your dial caliper, and expect to do a few test runs before you get your printer to make an accurate 1:1 image. There was a Yahoo Group devoted to home PCB fabrication; possibly called “DIY PCB” or something like that. (It’s probably still around, but I haven’t looked at it in many years.) They may be a source of help for questions related to toner-transfer production methods.


1 Like

So you started with a new transistor in EEschem:
“a”, “r”, [Enter], [LMB]
Then you edit it:
(hover + ‘e’)
Select “Footprints” in the “Fields” window -> Assign Footprint.
This brings you to the “Library Browser”. (You’ve already been there).
Then there is the 6 legged IC in the icon bar to open the 3D viewer.
If you put the “3d viewer” next to your library browser, you can instantly see what a component looks like if you select it in the library browser.
Once you found a nice Footprint click the “Insert Footprint in Board” icon. in the library browser.

Edit: repaired link(s), apparently something gets broken with file names with spaces.

Thanks Dale. I should have recognized ‘Plot’ as being a print option.

Thanks paulvdh, I like that idea of using the 3D viewer alongside the browser. I would never have thought of that.

Couple of things, though:
What is [LMB]?
If that was a link in the fourth-to-last line it doesn’t link.

I would guess the left mouse button

Blimey! :confused: Sometimes I am so dumb I amaze myself. :rofl:

That’s probably a culturally-conditioned response. D-size drawings - typically created on a classic pen-plotter - are almost never used in electronic design any more, so you look at the “Plot” option and think, “I don’t have a plotter connected to this computer. Heck, I haven’t even seen a pen-plotter in two decades.”. Then you mentally move on to the next choice.


bobc, will the script help on ubuntu 16.04 LTS where kicad is installed with SNAP? I just tried to update footprints and had to point to another location. I could not do anything about packages3d as there is no way to edit the path. SNAP does not know about the updated modules and libs.

The official libs use the environment variable KISYS3DMOD to find where the 3d models are. simply point that variable to your location and it should work. (I use this to switch between 3 different instances of the 3d lib. In kicad 4.0.6 and in nightly.)

The environment variables can be set in the kicad main window, preferences menu -> configure paths

Rene, Much of what I have to say is Linux only related (ubuntu 16.04 LTS and Kicad 4.0.4 Snap stable). I worked through your faq. Since it is ‘snap’ manual updating libraries and modules is not available. I created new paths to a local directory using Wizard for modules and a new search path with higher priority for libs. The big problem is with packages3D where the path(KISYS3DMOD) is not deletable or editable so I can’t point to another directory. This is very much a snap issue as the subdirectories 2 and current are virtual, my guess anyway.

The following modules cannot be added to footprint list as they do not have .kicad_mod files: Enclosures, HousingPGA, RelaysSMD, TerminalBlocks_Phoenix, TerminalBlocks_WAGO, WireConnection_Bridges.
Hope this is the right place to bring this up. I am willing to do some testing.

In the dialog i mentioned you need to duple click on the cell to the right of the variable name. Then you should be able to type in any path.

I think snap applications are limited to where they can write to. Not sure if there are limitations from where they can read.

This is fixed in the v5 libs. The v4 libs are already declared legacy and will no longer be maintained. (If we find a major problem we might fix it in the v4 libs but don’t hold your breath as we are struggling to get everything done for the v5 release)

My mistake - yes they can be edited.

Thanks Rene! Looking forward to 5. Your efforts much appreciated.

I guess that depends on the security settings of the Snap package, but I don’t really know much about Snap.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.