Legacy .mod files and KiCad V5.1.0

Details of version etc:
Application: kicad
Version: (5.1.0)-1, release build
wxWidgets 3.0.4
libcurl/7.61.1 OpenSSL/1.1.1 (WinSSL) zlib/1.2.11 brotli/1.0.6 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) nghttp2/1.34.0
Platform: Windows 7 (build 7601, Service Pack 1), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.68.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.61.1
Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:
Hello, I have just created a logo to use in KiCad according to this tutorial: https://www.re-innovation.co.uk/docs/adding-logo-to-kicad/ which produces a .mod (legacy) type file.
I created a folder for it called AD_logo on C drive, and copied the download to it (12KB).
I then tried to add it to the library by adding the folder and changing the type from KiCad to legacy in Manage Footprint Libraries. It then tries to load but gives the message:

12:27:56: Failed to open ‘C:\KK_AD_mod\modules\AD_logo’ for reading (error 5: access is denied.)
12:27:56: Failed to retrieve file times for ‘C:\KK_AD_mod\modules\AD_logo’ (error 5: access is denied.)

Everything looks OK, exactly as it did in V4.X.X when the library would be saveable as a .pretty file.
Is it possible to do this in V5.1.0?

Unfortunately these appears to be no easy way to scale logos with the bitmap2component converter, and the drawings I have of a company logo as dfx or bmp are far too large to use, hence the conversion.

Sounds like a permission issue. You might need to take ownership of that file/folder.

What do you mean there is no way to scale images in bitmap2component converter? DPI settings do exactly that. You just need to do little bit of math: 100x100 pixel image with 200 dpi will be 1/2x1/2" square.

Thanks for the help fellas,

I did eventually work it out. I was trying tooooooooooo hard!

I just imported the file and scaled it exactly as @qu1ck suggested above. Simple!

Also having the issue with a footprint downloaded from snapeda. The footprint is also in a mod file. The owner is me, the current user, and Kicad is running as an admin, so this error should not be showng unless the owner is TrustedInstaller, which it is not.

You might need to give us a lot more information. Do you get the access is denied message reported above? If so then yes your operating system does not allow kicad to read that file.

If you have any other problem then you might need to tell us exactly what is going on.

Same exact error. It happens in the footprint editor whenever the footprint libraries are loaded up, Can’t tell you much more; you didn’t tell me what information you need. Here’s a screenshot: http://prntscr.com/nohipr

.sym is not a kicad library file ending. And definitely not a one related to footprints. It might be either a spice symbol file or possibly the exported graphical info of a kicad symbol. (at least in v4 one could export either the full symbol resulting in a lib/dcm pair that can be directly used or export only graphics as a sym file which can only be imported via the symbol editor and must then be stored to a library to be accessible to kicad itself) scrap that there is no “.” between “esp32” and “sym” meaning i read it wrong.

New idea: give us the full file path of the files that make problems. possibly show them within the file browser.

And you might want to read: Library management in KiCad version 5

By the way you can drag and drop one image per post (as a new user) which will result in it being shown inline.

Good tip. So here’s how I have my library imported, followed by how the libraries appear in the specified folder. the how-to-import file is very outdated, and isn’t useful.

you need to add the mod file directly not the folder containing it. Same with the .lib file on the symbol side. (By the way that one is missing the .dcm file which would normally hold additional documentation information like the link to a datasheet)

Interesting. Alright. so I fixed it by appending “.mod” to the end of the path manually. Thank you!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.