Kicost is amazing tool, but for me it didn't work!


#41

Getting the same result

ajay@ajay-Lenovo-G500:~$ sudo apt-get install python3-pip
[sudo] password for ajay: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
python3-pip is already the newest version (9.0.1-2.3~ubuntu1).
0 to upgrade, 0 to newly install, 0 to remove and 2 not to upgrade.

ajay@ajay-Lenovo-G500:~$ sudo -H pip3 install -U pip
Requirement already up-to-date: pip in /usr/local/lib/python3.6/dist-packages (18.0)

ajay@ajay-Lenovo-G500:~$ sudo -H pip3 install -U -f https://extras.wxpython.org/wxPython4/extras/linux/gtk3/ubuntu-18.04 wxPython
Looking in links: https://extras.wxpython.org/wxPython4/extras/linux/gtk3/ubuntu-18.04
Requirement already up-to-date: wxPython in /usr/local/lib/python3.6/dist-packages (4.0.3)
Requirement already satisfied, skipping upgrade: PyPubSub in /usr/local/lib/python3.6/dist-packages (from wxPython) (4.0.0)
Requirement already satisfied, skipping upgrade: six in /usr/lib/python3/dist-packages (from wxPython) (1.11.0)

ajay@ajay-Lenovo-G500:~$ kicost
You don't have the wxPython dependence to run the GUI interface. Run once of the follow commands in terminal to install them:
pip3 install -U wxPython # For Windows & macOS
pip install -U -f https://extras.wxpython.org/wxPython4/extras/linux/gtk3/ubuntu-16.04 wxPython # For Linux 16.04
Or download from last version from <https://wxpython.org/pages/downloads/>

#42

Could you try by the GIT command
sudo apt-get install git
sudo -H pip3 install -U git+https://github.com/xesscorp/KiCost

or download manually downloading by https://github.com/xesscorp/KiCost/ and running
sudo -H pip3 install -U setup.py # From the folder that you downloaded and extracted
?

Appear that the version of the pip (official release) have a import problem already fixed on new codes.


#43

I installed using GIT it successfully installed but manual installation not

ajay@ajay-Lenovo-G500:~/Desktop/KiCost-master$ sudo -H pip3 install -U setup.py
[sudo] password for ajay: 
Collecting setup.py
  Could not find a version that satisfies the requirement setup.py (from versions: )
No matching distribution found for setup.py

and the problem still persist


#44

No, install the GIT
sudo apt-get install git

After install KiCost using the GIT (which take the last code version on the development)
sudo -H pip3 install -U git+https://github.com/xesscorp/KiCost

The command
sudo -H pip3 install -U setup.py
install when you download accessing the web page and download by your self. So this you will not use, @ramprasadajay.


#45

Yes, I did the same thing. I installed git and then installed Kicost using git as you mentioned, it successfully installed kicost 0.1.47 and when I tried running kicost it returning the same message. Then I tried installing it manually but that installation returning with error as I showed you in the previous reply


#46

When you type
python3 -c “import wx; print(wx.version())”
still getting error? The answer should be
4.0.3 gtk3 (phoenix) wxWidgets 3.0.5

Did you reinstall wxPython be the command
sudo -H pip3 install -U -f https://extras.wxpython.org/wxPython4/extras/linux/gtk3/ubuntu-18.04 wxPython
?

Appear that package still missing.


#47

I reinstalled wxPython and ran that command it returned the result. But when I tried to run KiCost I got this error msg, I installed Libreoffice also but getting the same result

ajay@ajay-Lenovo-G500:~$ kicost
/usr/bin/libreoffice: 174: exec: /usr/lib/libreoffice/program/oosplash: not found
Traceback (most recent call last):
  File "/usr/local/bin/kicost", line 11, in <module>
    sys.exit(main())
  File "/usr/local/lib/python3.6/dist-packages/kicost/__main__.py", line 239, in main
    kicost_gui() # Use the user guide if no input is given.
  File "/usr/local/lib/python3.6/dist-packages/kicost/kicost_gui.py", line 990, in kicost_gui
    frame = formKiCost(None)
  File "/usr/local/lib/python3.6/dist-packages/kicost/kicost_gui.py", line 293, in __init__
    subprocess.check_output(['libreoffice', '--version'])
  File "/usr/lib/python3.6/subprocess.py", line 336, in check_output
    **kwargs).stdout
  File "/usr/lib/python3.6/subprocess.py", line 418, in run
    output=stdout, stderr=stderr)
subprocess.CalledProcessError: Command '['libreoffice', '--version']' returned non-zero exit status 127.

#48

Hurry! it’s working @hildogjr. I installed libreoffice by command line instead of downloading deb package fixed the error. Thank for the help @hildogjr and developing this amazing GUI for this amazing plugin.


#49

Now I am getting this error while I press Kicost It! @hildogjr

(kicost:5282): Gtk-CRITICAL **: 18:07:38.902: gtk_box_gadget_distribute: assertion 'size >= 0' failed in GtkScrollbar
[xcb] Unknown request in queue while dequeuing
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
python3: ../../src/xcb_io.c:165: dequeue_pending_request: Assertion `!xcb_xlib_unknown_req_in_deq' failed.
[xcb] Too much data requested from _XRead
[xcb] This is most likely caused by a broken X extension library
[xcb] Aborting, sorry about that.
Aborted (core dumped)

#50

I got this intermittently. Please, generate a bug/issue track on the https://github.com/xesscorp/KiCost/issues (also in the about tab of KiCost have a link for this).