KiCad cannot save or create files


I suddenly cannot create new projects or save any files in KiCad. For example, if I try to create a new project, I get the following error message: “full file File not found. Check the filename and retry.”
What’s going on there? I’ve got the Version 5.0.2 running on Windows 10, and also tried reinstalling KiCad without success.

Kind Regards


Have you been using “Run as administrator”?
Never use Run as Administrator to start KiCad. You will end up with projects that cannot be opened by a regular user

This is a pure guess, but have you tried to save in your “My Documents” folder. You should have full access to it. This is assuming it is a rights issue which we don’t really know at this point.

I’ve already tried to run it with administrator rights, and I’ve also tried to save in the “my documents” folder.

Does your filename contain “exotic” characters (ie not letter/figure) ?

No, neither the path nor the filename contain any exotic characters.

Can you give a screenshot of the message dialog?

When giving user interface texts in English they should be taken directly from the English user interface, not backtranslated. In this case I tried to search for the text given by you from the source code but didn’t find it. Can you change the language to English and give the text again?


Another guess…

Perhaps the path is too long or some unseen issue. You might try saving directly in Documents.


Stupid questions:

  • Ensure you have enough free space on that volume / disk
  • Did you tried to save in another folder / hierarchy ? I mean outside the /Documents folder.

Actually, I wonder if the error message really comes from KiCad or rather Windows itself.

1 Like

I was starting to wonder about that as well, but the 2nd screenshot has “Schnellzugriff” & “Dieser PC” (= German from OS) intermixed with English in the “Create New Project” (Language chance in KiCad) window.
But: “Es wurden keine Suchergebnisse gefunden.” is clearly a German error message while KiCad should be English now.
It seems that his German Windows is generating an error messge which is translated to English by KiCad.

What happens when you try to open / save files with another program (Text editor) in those locations? All KiCad files should be human readable text.

What happens if you start KiCad from a command line?
I have KiCad Version: 5.0.2+dfsg1-1, release build
and it still puts out assertion failures ( which is normally only done by debug versions).

When I start KiCad from the command line, the first thing it does is spitting out a bit of debug info on my linux box:

paul@dualcore:~$ kicad
10:23:10: Debug: Checking template path ‘/usr/share/kicad/template’ exists

I just tried to save it outside the documents folder, it worked. Strangely, KiCad is the only software I have currently installed which shows this error. Any ideas what could cause this?

You said you had also run KiCad as Administrator.
It is possible you created that directory while being administrator, and now you can not write to it while being a normal user.
To verify, look up the rights of that folder or try to save files in that same location with another program.

1 Like

I would check the " Controlled Folder Access". Check this page (for example) for more information.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.