KiCad 5.0 should I upgrade from 4.07?


#21

Hi Rene,
Yes i remember you warned against doing so.
At that time, it was the only way i found to ensure getting rid of the v4 legacy.
I gave your suggestion a quick try and the tool returned a message like “there are no symbols to rescue in this project”.
So far i didn’t have the time to try again to verify if i missed something in the quick test i mentioned earlier, i promise i will try again and post the results.


#22

You started the symbol rescue dialog. in the same menu there should be a “symbol library reference editor” (I am not 100% certain about the exact wording as i run a nightly build with slightly differing user interface)


#23

Another point about 3D objects. The footprint itself has a pointer to the filepath of the intended 3D object (much like the symbol in the schematic has a pointer to the footprint). Because when laying out a board the used footprints are embedded in the pcb file, changing the 3D object filename in the library footprint won’t be reflected on any board until you reload the footprints on a board from the library. That is one of the reasons for doing step #12 in my procedure, above.

But, also, the 3D library included with KiCad doesn’t actually have a 3D object for every footprint in the included library. Generating 3D objects is a labor intensive task and our librarians are all volunteers. It is unfortunate, but reasonable, that they haven’t gotten to everything. And for a feature that isn’t critical to the functioning of designing circuit boards for most workflows, an incomplete 3D object library isn’t a reason to hold up the release.

There are actually some footprints that have 3D object settings, but the 3D object files don’t actually exist. This is (probably) done because the librarians know what the filename of the 3D object should be so they put it into the footprint. Once the object files are created (and vetted) they only need to add them to the 3D library instead of also having to update the footprint libraries.


#24

A good day to everybody, and big thanks for your support!

I tried again importing a v4 project in my clean v5 installation and yes, the symbol remap tool you mentioned started automatically. There is a dedicated “Remap symbols” menu item just under the Symbol Rescue line; once the Remap Symbols tool has been run, the corresponding menu item gets disabled.

I looked closely into the contents of the modules and modules\packages3d folder and noticed that:

  1. the 3d files have mostly the same name of their corresponding footprint, but some have a slightly different name, like 1x05 instead of 01x05 for some connectors. This can be adjusted in the footprint properties dialog.**
  2. not all footprints have the 3d counterpart, probably its just a matter of patience.

#25

I’ve updated from 4.07 to 5.0 without any problem. I have just backed up the old Kicad directory and created new and copied only project and old libraries I want to use in the future. Then I just followed @SembazuruCDE guide and all libraries are loaded fine. After I uninstalled the 4.07 I have removed the PPAs just in case. After that I have installed v5 from PPA and then cloned all templates/symbols/3Ds/footprints from Github and then set global variables.
I am now at point 11.2 of @SembazuruCDE guide and I plan to update the footprints using “Edit Symbol Fields” command. This tool is awesome as it allows you to copy/paste the values of footprints. I think I will be finished for this project in under an hour. But I’ll do that tomorrow.
My dir structure looks like below. I plan to just copy/paste that on all machines

Kicad/

  • libraries
    • local
      • downloaded
      • footprints
      • packages3D
      • symbols
      • templates
    • official
      • footprints
      • packages3D
      • symbols
      • templates
  • projects
    • project1
    • project2
    • project…

#26

Just to let you know guys I finally fully upgraded my project to Kicad 5. I copied the project on 3 different Linux machines and works perfectly on all 3 slightly different versions on Linux Mint.
On 2 other machines that I copied the project to I just uninstalled the Kicad v4 and deleted local directories including ~/.config/Kicad and managed to just copy that from original computer without any problems after instaling v5. Directories were the same so it went smoothly. I am just completed upgrading all footprints using Update PCB from Schematic. I love that functionality. I’ll sleep on it and order prototype board just to be sure before I go into production.
Thank you all…


#27

Not sure how to do this. Linux MINT 18.3


#28

I’m not familiar with Linux. Maybe try googling how to modify environment variables in Mint?


#29

Unless you explicitly set them in Linux, you don’t need this step.


#30

Thank you! I will keep that in mind.


#31

I confirm this. I have ver 5 now installed on 4 machines linux Mint 18.3/19 and all running smoothly by just following above install procedures without setting enviro variables and just copying library/project installation dirs.