Is it possible to set line width on the fly?

pcb
just opening a board and pressing control+w will kill it

Agree!!

Application: KiCad

Version: 5.99.0-unknown-21fde9b629~128~ubuntu20.04.1, release build

Libraries:
wxWidgets 3.0.4
libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3

Platform: Linux 5.4.0-72-generic x86_64, 64 bit, Little endian, wxGTK, cinnamon, x11

Build Info:
Date: May 1 2021 08:46:57
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
Boost: 1.71.0
OCC: 7.3.0
Curl: 7.68.0
ngspice: 31
Compiler: GCC 9.3.0 with C++ ABI 1013

Build settings:
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_PYTHON3=ON
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_WXPYTHON_PHOENIX=ON
KICAD_SCRIPTING_ACTION_MENU=ON
KICAD_USE_OCC=ON
KICAD_SPICE=ON

It’s not crashing it …
image

The hotkeys used to change the track widths are W and Shift+W.

1 Like

Funny

I have never used the shortcut before and after reading iabarry post above gave it a try.
Shift+W reduces the track width OK apparently in nightly

Carry on…

I switch grids all the time (long right click, grids submenu way…). I tried CTRL+SHIFT and it did nothing for me (Using windows 10 with KiCAD v5.99). However if I hold ALT, then I get the behaviour of the grid being ignored (object can be precisely positioned). If I release ALT while dragging the object stays stationary and moving the mouse does nothing, then when one clicks, the object appears at the click. Is CTRL+SHIFT supposed to work for windows?

I have written:

I use it in Windows 7, but KiCad 5.1.10.
I don’t have Windows 10 so I didn’t tried v5.99 so I have no way to check if there really CTRL+SHIFT don’t works.
But… - haven’t you read too fast what I have written - meaning have you noticed “at schematic” in my sentence?

I tried the schematic and pcb editor, and both had the same behaviour. Maybe they moving towards using ALT instead for v6, I guess its easier to press.