Inventory Management (Open Source!)

This is a tool I really need.
However, some of the dependencies does not seem to be available in Fedora 30’s repos.
Anyone that’s installed this in Fedora 30 64bit?

On a related note :slight_smile:

3 Likes

Hey @rco3 sorry that you’ve run into this problem. I think I have worked out what might be going wrong.

This might be the faulty step in the docs:

Can you please try the following for me. Once you get to this step, run:

cd InvenTree && python3 manage.py runserver 127.0.0.1:8000

I suspect that there is an issue with regards to which directory you call the script from, if (and only if) you are using an SQLite database.

Please let me know if this fixes the problem, and I’ll fix the script and the documenation.

Cheers

Would please post an howto to create this kind of local installation?

I just performed a local installation following the getting started documentation here:
https://inventree.readthedocs.io/en/latest/start.html

1 Like

The “out of the box” install process sets up a local filesystem database - using the SQLite file-storage database backend.

You can get this up and running (on Windows) in two ways:

1. Make for Windows

If you have make.exe installed in your system path, and you also have python3 / pip3 installed then you can follow the process described in the “getting started” guide, directly from cmd.exe shell.

2. Windows Subsystem for Linux (Recommended)

The process is much simpler under WSL - https://docs.microsoft.com/en-us/windows/wsl/install-win10

The same process in the “getting started” guide can be followed from the Ubuntu shell.

WSL is recommended for two reasons:

a) The apt-get system is much easier for installing packages
b) You can run the gunicorn server under WSL but it is not supported on Windows natively

If you follow the getting started guide without any modifications to the config.yaml file, then it will create a new database file called inventree_db.sqlite3

For example here is a local install running from ubuntu shell

1 Like

@joost I have worked out a way to allow extra URL schemes to be added to URL fields. The database administrator can now choose to allow extra URL schemes in the config.yaml file. By default no extra schemes are allowed. This means that it is up to the user / administrator to select which extra schemes they want, while not altering the default behaviour.

No, no, please don’t apologize. I’m grateful for your work, hope to help in whatever small way I can to improve it.

That does, in fact, appear to have solved the problem. Now I can navigate to the locally-served webpage and see an empty system, ready for parts to be added, and no errors in the terminal window from which I launched.

I’m all excited now. Thanks for all this.

1 Like

Thanks! It almost works;

With config.yaml now set to:
extra_url_schemes:

  • mailto
  • x-devonthink-item

If I set the part URL to e.g. x-devonthink-item://1C1E931E-1A30-4515-BCF9-45CDF39B56EC, invenTree does not permit saving the item. However, if I stick “.com” (or dot anything for that matter) at the end, it saves it. The same is true for mailto, a setting mailto://testing does not save but mailto://testing.com does.

If the part is stored with URL x-devonthink-item://1C1E931E-1A30-4515-BCF9-45CDF39B56EC.com, devonthink does indeed open but cannot find the specific document (of course) so it seems that if that dot-anything requirement is removed this would work smoothly.

Got it working, thanks for a great tool.
I had downloaded the. zip, started over with “git clone xxxxxxxx…” and for some reason it works now.

Edit: Added picture

1 Like

Same here. 20…

I’ve spent a a couple of hours putting parts in to InvenTree and I am about 80% through my 0403 resistors…
It’s a pain when first putting all parts in lol

@mayday I think I can save you some time. There is now a bulk import function, available in the Admin interface.

Follow the steps below to access it:

Note: If you first export the parts list you will get a pre-formatted template that you can then use to import the data. The import function requires strictly formatted data for import, so this template file is helpful for this.

1 Like

Thank you, both for the software and the support/help!

Edit: I used the .csv file InvenTree created when exporting the parts. When I added some parts exactly like the parts already there. I got a bunch of error messages about line 1 and something about id.
I didn’t take any screenshots unfortunately.

I have now added the ability for InvenTree to be translated / support multiple languages. This simply requires translations to be added via .po files.

If there is anyone here who is interested in providing non-english translations, please think about submitting these here - https://github.com/inventree/InvenTree

The translation framework is now completely integrated, it just needs some clever bi-linguists to provide the translation data :slight_smile:

2 Likes

@SchrodingersGat it looks pretty cool. I have not tried it, but you may want to submit a pull request to get it listed on the website if you like:

It is a interesting project. Could you give me for details about the API/Python integration?
I am think about the KiCost integration as a local distributor/stock.

Python interface - https://github.com/inventree/inventree-python

API - https://inventree.readthedocs.io/en/latest/rest.html

This is one of the more useful pieces of software I have, not having to look through binder after binder to check if I have a specific part is great.
Thanks again!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.