Installation errors kicad-4.0.5-i686.exe is not a valid Win32 application (solved)


#21

Approximately half the time, my home internet connection requires over an hour(!!) to download a KiCAD installation package, and may abort the download before it finishes. I have never tried to examine the truncated files left after a failed download but it is plausible that they contain an error message. This behavior (failed downloads) seems to depend on the Internet service provider (ISP) - I have downloaded KiCAD installation packages at work, over public WiFi networks, and about half the time at home, and it takes only 4 to 5 minutes.

If you are experiencing incomplete downloads, try downloading from a different location.

Dale

p.s. - Can anybody explain why my home connection (supposedly an up-to-date “high speed” internet service) sometimes downloads the KiCAD files in only a few minutes, and other times needs an hour or two? I haven’t noticed the problem on any other web site.


#22

For private customers (ie. Joe Average at the end) the first thing usually is congestion for such troubles (ISPs also ‘shape’ traffic by restricting certain services during such times), as in 99.99% of the cases you get hooked up with a lot of other people, thus you’ll notice speed differences for your service due to too many users using a limited pipe now and then.
You’d need to run some speed/link/packet loss tests during those times when you have trouble with your connection to find out whats going on - there are a couple of websites and tools dedicated to this out there - but I’m not knowledgeable in that area to give advice on what and where to look for this really (personally I’d probably turn to stack-overflow, superuser section for help in that regard) as this also depends on he OS you use.
Or you got some ‘funny’ software on your machine at home - unless you’ve been using the same machine in all other cases, ie. a laptop which would rule that option out.

Anyhow, if you’re on a ‘flaky’ line that has troubles with big downloads, the first thing you need to make sure is to use a download manager for your browser.
This will eliminate 95% of troubles in regards to ‘broken’ downloads.
The ones that are included in the browsers have become better over the years, but my personal experience is that a download manager still beats them for getting me large files (>100mb) as they can open several connections to the source and try to get the file bit by bit if they have to, even if the connection drops in-between - you can even restart the computer and they will keep going afterwards.
I use DownThemAll with Firefox, no idea if there is better out there. And as always, I’m not affiliated :wink:


#23

If you end up with a couple of hundred MB, but too small, the problem is a network or server stall and timeout.
Very short files like the OPs 2kB point at a failure to fetch anything. This is sometimes down to your ISP or a false positive from antivirus software. For some months now Firefox has been identifying some of the Sourceforge servers as having bundled malware. There was a minor problem with a few packages, but this is generally a false accusation.


#24

Hi All

Thanks for the awesome help. David your link got me the correct download, I really don’t know what the problem on the website with the other download was but I’m sorted for now thanks yal.