Installation errors kicad-4.0.5-i686.exe is not a valid Win32 application (solved)


#5

Sounds to me like you are installing a 64 bit version on 32 bit Windows.


#6

Is the 32 bit version


#7

Hi

Thanks for the advise, I switched off my firewall and I tried to install both 64bit and 32 bit versions.

The 32bit version gives this error:

kicad-4.0.5-i686.exe is not a valid Win32 application

The 64 bit gives the error:

kicad-4.0.5-x86_64.exe is not a valid Win32 application

I can only install the 2013 vesion so I guess I have to work with that now.

Thanks all


#8

Is it (edit by Joan: Windows) 32 or 64 bit version?


#9

Noooo! … no one will be able to help you really as that thing is outdated and so far back, it’s not funny anymore. Please have a heart :sweat:

  1. can you please tell us the bitness of your windows as @bobc asked?

(64bit programs don’t run under 32bit Windows and produce the error you observe…)

  1. can you check that the download is not corrupted (essentially answering @davidsrsb 's question) ?

(as both files, 32bit and 64bit cause the same error we can assume you got a different problem, maybe corrupt downloads… reason? damaged memory modules in your computer, broken router, etc…)

This is what the downloads look like for me in Windows 7 Home Premium 64bit and both are start-able:

PS: hashtab is an addon I installed some years ago. Use at your own risk. I’m not affiliated.

PPS: first indication of badly corrupt files would be different file sizes (in bytes as you can see them under Properties>General). Not so badly damaged files will have different checksums but the same size, thus the hashtab addon.


#10

I googled for the error, and found a surprising number of things that can go wrong that are not down to the downloaded file being corrupted or anything, but some incompatibility with the windows config. e.g. https://answers.microsoft.com/en-us/windows/forum/windows_7-windows_programs/windows-7-and-exe-is-not-a-valid-win-32/8f8c4d85-5015-47ec-82d1-5d0ebe7a8bd4

It’s a kind of typical “something went wrong” Windows error. Personally I might try Dependency Walker but that is more of a dev tool, not really designed for regular user.


#11

So far everyone who has verified that they can run both images is also running 64-bit Windows. Both installers should be 32-bit programs anyway. I did notice though, since 4.0.4 the installer’s language has changed to Greek. Was English in 4.0.2 but previous versions didn’t contain any version information. Not sure if that could be an issue though.


#12

kicad-4.0.5-x86_64.exe is a 64 bit build and installs in “C://Program Files”, not “Program Files (x86)”, where legacy win32 apps go.


#13

kicad-4.0.5-x86_64.exe is a 32-bit executable that installs a 64-bit build.


#14

Well it is not suitable for installation on a 32 bit Windows PC


#15

Well thank you for pointing that out, although it was never implied that it was. But I’m sure you’ll correct me.


#16

What does Start-ControlPanel-System-“System type” say?
That is the line that identifies 64 or 32 bit Windows


#17

Hi all

On my PC: Start-ControlPanel-System-“System type” says 64 bit Operating system.

Joan & David sorry I didn’t read your posts attentively, I think you were right the setup files I download are not correct it is only 2KB size files and I get them from this website: http://kicad-pcb.org/download/windows/ . This might be my problem do you perhaps have a link to the correct exe files?


#18

Oh sorry David I did not check the file size mine is incorrect what might have caused this?


#19

That’s the correct source.
If they are just 2kb after downloading you either saved the html link by accident and didn’t wait for the download dialog to pop up and ask you where to save them or something else went wrong?
If you can, re-download the _64 file again and make sure you get the 344MB on your end.


#20

Try http://downloads.kicad-pcb.org/windows/stable/kicad-4.0.5-x86_64.exe again, which is the correct version for you.
Do you have a firewall in the way? If you get the 2kB again, try opening it with Notepad as it may contain an error message


#21

Approximately half the time, my home internet connection requires over an hour(!!) to download a KiCAD installation package, and may abort the download before it finishes. I have never tried to examine the truncated files left after a failed download but it is plausible that they contain an error message. This behavior (failed downloads) seems to depend on the Internet service provider (ISP) - I have downloaded KiCAD installation packages at work, over public WiFi networks, and about half the time at home, and it takes only 4 to 5 minutes.

If you are experiencing incomplete downloads, try downloading from a different location.

Dale

p.s. - Can anybody explain why my home connection (supposedly an up-to-date “high speed” internet service) sometimes downloads the KiCAD files in only a few minutes, and other times needs an hour or two? I haven’t noticed the problem on any other web site.


#22

For private customers (ie. Joe Average at the end) the first thing usually is congestion for such troubles (ISPs also ‘shape’ traffic by restricting certain services during such times), as in 99.99% of the cases you get hooked up with a lot of other people, thus you’ll notice speed differences for your service due to too many users using a limited pipe now and then.
You’d need to run some speed/link/packet loss tests during those times when you have trouble with your connection to find out whats going on - there are a couple of websites and tools dedicated to this out there - but I’m not knowledgeable in that area to give advice on what and where to look for this really (personally I’d probably turn to stack-overflow, superuser section for help in that regard) as this also depends on he OS you use.
Or you got some ‘funny’ software on your machine at home - unless you’ve been using the same machine in all other cases, ie. a laptop which would rule that option out.

Anyhow, if you’re on a ‘flaky’ line that has troubles with big downloads, the first thing you need to make sure is to use a download manager for your browser.
This will eliminate 95% of troubles in regards to ‘broken’ downloads.
The ones that are included in the browsers have become better over the years, but my personal experience is that a download manager still beats them for getting me large files (>100mb) as they can open several connections to the source and try to get the file bit by bit if they have to, even if the connection drops in-between - you can even restart the computer and they will keep going afterwards.
I use DownThemAll with Firefox, no idea if there is better out there. And as always, I’m not affiliated :wink:


#23

If you end up with a couple of hundred MB, but too small, the problem is a network or server stall and timeout.
Very short files like the OPs 2kB point at a failure to fetch anything. This is sometimes down to your ISP or a false positive from antivirus software. For some months now Firefox has been identifying some of the Sourceforge servers as having bundled malware. There was a minor problem with a few packages, but this is generally a false accusation.


#24

Hi All

Thanks for the awesome help. David your link got me the correct download, I really don’t know what the problem on the website with the other download was but I’m sorted for now thanks yal.