How to get track on a QFP 32

Hello, this my first attempt to route a QFN32. I take a track of 8 mils but I cannot connect it to the QFP pad. I have try to change the isolation pad to 2 mils but doesn’t work. Could you help a newbee to smd ?

There are over 30 different QFN footprints with 32 pins in KiCads default libraries:

and they have different pitch for the pins. from quite small 0.4mm to bigger and easier manageable pitches.

If you want tracks to connect to the pins, you have to make sure that the with of the track plus the clearance is less then the pitch of the IC used.
A clearance of 2mil is quite small. Once stuff gets that small you have to divide the available space over the track width and the clearance. Something like a 5mil track width and a 4mil clearance seems more sensible.

With such small dimensions you also start getting in the neighborhood of what PCB manufacturers can make, so you have to verify this with what your PCB manufacturer can make (for a certain price). For 4-layer PCB’s, you can usually go to smaller dimensions then for 2 layer PCB’s. (Even for the same PCB manufacturer).

Thanks for your answer
I have taken the 4*4mm ep 2.65 which correspond to my chip. 5 mils track seems very small can’t use 8 mils ?

With your info there are still 4 different footprints to choose between:

However, with the smallest you have a pitch of 0.4mm, which is close to 16mill, so you may be able to use 8mill tracks and 7mill clearance. But I haven’t seen your design so I’m just guessing here. Maybe the cause of your problems was something entirely different.

I am sorry a QFP32 4x4mm

There is no 32 pad device which both satisfies “qfp” and “4x4” in KiCad’s default libraries.

I also have no more motivation to anticipate in this guessing game.
My suggestion to you is to spend some quality time on:
http://www.catb.org/~esr/faqs/smart-questions.html

… and then reformulate your questions a bit more carefully.
After that somebody else may be willing to answer your questions.

1 Like

Presume you mean QFN 32 4x4 of which there are two footprints in the library differing only in thermal pads.
KiCad has fairly cautious design rules for clearance etc and it may be that this footprint required tighter tolerances than the default setup allows. You might to check with your manufacturer what they are capable of and see if reducing the design file clearances and track widths will allow you to route this pretty tiny component.

Hi John
Yes I use this footprint with no thermal pads. My pcb manufacturer allows 5 mils track and clearance. I try a 6 mils and 8mils track thickness and I can’t connect track to pad of this QFP 32. Each pad is 0.2mm (8 mils).May be there is somewhere a rule to uncheck but I don’t find it.

In interactive router settings (route menu) switch to highlight collision mode and you will see why you can’t connect tracks.

1 Like

You might want to take a look at your clearance settings of the netclasses involved. Just in case this is news to you here the link to the respective section in my getting started tutorial Tutorial: Introduction to PCB design with KiCad version 5.1 (Getting Started)

Thanks a lot . this was the solution (the highlight collision)I have change my default setting to 0.2mm and it works. I will remake all my netclasses.