How can I hide GND ratsnest or assign parts of ratsnest to different layers?

Hi, I’m migrating to KiCad from Diptrace and I can’t figure out how to turn off ratsnest. In Diptrace, when I route a board, I segregate and hide different nets and do V+ and GND last or first. How do you tackle multiple layer boards on here? Suggestions? Best practices?

Sorry, but there is only a global ratsnest show/hide option right now.

I think a workaround to have the GND (or any) ratsnest disappear is to create a ‘temporary’ filled zone for GND that covers everything.

PS: in the legacy toolset (Preferences > Legacy, or alternatively [F9]) if the ratsnests are globally disabled it will show the ratsnest for the footprint that you pick up and move…

1 Like

I’ve figured out how to set up a ground pour, but I can’t complete the task. I can draw the box, but Enter won’t let the drawing tool disengage. I found a drop down menu if I scroll over Zones, but Fill All doesn’t work. Some pop up menu flashes too quickly for me to make out what it says when I click on Fill All.

hit [B] or right click on the zone and look for ‘(re)fill’ in the options

1 Like

Does this help for the zone?

1 Like

I tried that and it won’t complete the task. I press B or Fill All and it goes right back to edit mode.

Conditions for a zone to fill (of the top of my head):

  1. there needs to be a pad from a footprint of that net within the zone on the same layer
  2. and the zone needs to be within a closed outline
1 Like

Is it possible that you haven’t completed drawing the polygon? The last click has to be on top of the first corner point so that it will be closed, or you can double click in the last corner and the last line will automatically be drawn and the polygon closed.

1 Like

It was one of my first to check how to do it. At the level of KiCad 4.0.7 I have checked that I can manually delete GND net in netlist file (but under Windows 7 not using Windows Notepad but other editor (Notepad++)).
Shortly I will use KiCad, but not yet. I didn’t checked the method with Zone.
I suppose that you have nothing with the GND net at the layer you have put the GND zone so it is not filled with B key.

Also, if you want to hide multiple nets, you can (temporarily) up the number of layers and use several of the internal layers to hide nets.

I have KiCad V5.1.0 and Zones are always closed polygons.
No need anymore to match endpoints to close a zone.

While drawing a zone, you can end it by pressing [End] (which cancels the last point) or you can double click with the mouse, which adds the cursor position to the Zone coordinates.

The whole ratsnest can be turned on/off with:

Pcbnew / View / [ ]Show Ratsnest.

On the right there is also a button “Show local ratsnest”, but I have not figured out how it works yet. It seems that the local ratsnest while drawing tracks is always shown.

1 Like

Sometimes, even if by pressing [B], my experience has been that the zone is not filled. But do a DRC (even if you do not need one straight away) and PCBNew repaints the zone.

I finally figured it out. I need to right click and click on Close Zone Outline. You would think the Enter button would do the trick, but I guess not.

Yes, I think this is one of the most frustrating parts of laying out a new board. Is this feature on the list of things to fix in the next version? The trick I use is to create a copper fill for GND and then hide it via the “Do not show filled area in zones” option. And then hit the ‘b’ as I move parts around to reconnect the gnd as I move them. (assigned to version 6)


Looks like it (but can be 2 years or more away… so don’t hold your breath, on the list at 11:31 for v6 roadmap):


Holy smokes! Drag footprints with traces connected? Is that really a coming feature? Awesome.

Thanks for the links and bug reports for the net stuff. This community is awesome.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.