Housing_LCC PLCC-44_THT-Socket is not usable in 5.x

Hi all,
First of all I would like give some kudos to the people that have made all the footprints in 5.1.
There are however room for improvements. The footprint I mention in the subject have errors in it which makes it unusable unless changed.


As you can see there are two pins 29 which makes every pin after that misplaced. Pin 41 is overlapped with pin 38 which I don’t understand how the error checker can allow, nor two pins with the same number.

I don’t know whether this is the right forum to submit a bug report or not but it’s getting tedious to correct this footprint every time I want to use it.


That was fixed quite a while ago. https://github.com/KiCad/kicad-footprints/commits/master/Package_LCC.pretty/PLCC-44_THT-Socket.kicad_mod

I installed kicad 5.1 via an Ubuntu repo and it hasn’t been fixed there or am I missing something.

I use git and stay synced to the main repo:

How do you do that? Where can I find info/documentation to use git for the footprints?

In this excellent FAQ Library management in KiCad version 5 (sections " Personalized setup for the official library" and " Using a local git repository").

1 Like

Setting up is easy. You can find the clone instructions for git pretty easy. I use this to stay updated:

# Script to update Kicad Version 5 libaries from github

cd kicad-packages3D 
git fetch https://github.com/KiCad/kicad-packages3D.git
cd ..
cd kicad-symbols 
git fetch https://github.com/kicad/kicad-symbols 
cd ..
cd kicad-footprints
git fetch https://github.com/kicad/kicad-footprints
cd ..

I just checked, and in my KiCad V5.1.2 it has also been fixed. ON my HDD the file:


has date 2018-12-03, so it must have been fixed quite some time ago.

Johan’s post #3 links to github which suggest it was already fixed in 2017-11-16
The weird thing is that was still in the era of Kicad 4, while the Kicad 4 libraries had plural names (Packages_… instead of Package_… , etc).

I found the problem. When you upgrade KiCad it doesn’t update the libraries. You have to purge the package first, after that everything started to work as expected.
apt purge kicad and then apt install kicad with all the trimmings.

Purging might not get rid of your personal settings. See I had KiCad 4 installed previosly. Now i updated to v5. Now i have some problems with the library setup

That is true. I also rm -fr .config/kicad (I think the directory was called). After that everything was fine.

1 Like

I’m always a tad more timid. mv .config/kicad .config/kicad.bak0 1 2 3 whatever. Or use a date code with a letter. Depends on how often I think I might need to do this.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.