Good RF connector schematic library and footprints


Ok, this could probably be of less pain if I haven’t decided to manually delete old version folders that the apt couldn’t remove due to those folders not being empty. That pop up window you said it should pop up, it did but the 1st option that was to use the default global library was greyed out. heheh. Anyway I think I don’t need to open these old projects because I already have them on PCBs, so it’s probably ok.

I’ll be trying to figure out now the new version and try to find the SMA connector schematic symbols and later the footprints.


This is what I’m asked to input and not sure what to do!


It tells you what to do if you are not sure…


Indeed. It tells me to use the default selected option. But the selected option asks me to find some file that I have no idea where to pick it up from! I also don’t know if I choose the last option, what to do next or even if my Kicad is coming completely empty of symbols and footprints.


I think that’s what I did and I think one gets created when you choose the empty option the first time you add libraries to a project.


I just selected to create a new Global table and now my Kicad is 100% empty! :expressionless:

Now I tried to add the GitHub site link in PATHS but that gives a warning message and if I restart Kicad, that link is gone again!


I don’t know why this always gets so complicated.

To add libraries, use the library table manager.


This is something the packagers should have taken care of. They also sometimes have a tendency to hard code things that probably shouldn’t be hard coded.

See above though. Add the libs to your first project and I think you are good to go after that.


Ok, but where do I find those libraries??? Where are they? Which folder?


The repos doesn’t list files. First, you have to install the libraries separately. Make sure you have done this. Your package manager should tell you where they are installed. Probably something like /usr/share/libs/kicad. Maybe /usr/share/kicad.


I did previously “sudo apt-get install -t stretch-backports kicad” and it installed what it had to install. You mean I need to install any other packages?

These packages are all installed:
kicad-libraries - Virtual package providing common used libraries by kicad
kicad-footprints - Footprint symbols for KiCad’s Pcbnew
kicad-packages3d - 3D models for 3D viewer in KiCad’s Pcbnew and Footprint Editor
kicad-symbols - Schematic symbols for KiCad’s Eeschema
kicad-templates - Project templates for KiCad

But in /usr/share/kicad/

there are a couple of empty folders! Nothing inside!


Ok, now help is gone.

I can’t even clone the symbols repository from github. Pub Key denied!


Usually the Debian packagers are a little more on the ball.

There is an email on this page you might want to check out.;dist=unstable


Instead of cloning, you can download the zip, either from master branch or release tags.


@hermit I’ll give it a read! As of now, I just did things my way and I have no idea if it’s the correct way.

I have downloaded zip files for footprints, symbols and templates, created folders in /usr/share/kicad for them and extracted the zip contents into them. Then in kicad settings I edited PATH settings to point to these folders and added the iibraries and footprints in their respective managers!

@bobc ok, thanks, but why is this returning this Puiblic Key errors? Isn’t this supposed to be available to anyone?


It’s a github issue


He can also use https access instead of ssh. For read only this should be totally ok.


Here is the proper coaxial connector symbols from IEC 60617 that is found in IEEE 315A:


Recreating that exact symbol might be tricky with the limitations of kicad (unless you make it huge)


Which limitations you’re referring to?

Something like this: