Fixing footprint library path 4.0.0-rc2?

KiCAD 4.0.0-rc fresh install on Mac OS X 10.11.1

After many problems with old projects and libraires, I created a blank project to test/fix the install.

Since I initial had troubles with libraries, I installed the extras, moved fp-lib-table in ~/Library/Preferences/kicad

Using Eeschema, ->Preferences -> Composent Libraries
I added everything I found from ~/Library/Application Support/kicad/library

Seems to work. I made a dummy circuit, annotated components. Then I generated the netlist.
Then I tried to open CvPCB.
A huge error window pops-up (that cannot be closed because button is out of the screen, and there is no scroller, then I am forced to kill KiCAD from Force quit menu).
It starts with:
Errors were encounterd loading footprints IO_ERROR: footprint library path ‘/Library/Application Support/kicad/modules/Choke_Toroid_ThroughHole.pretty’ does not exit from /Users/jenkins/remoteroot/workspace/KiCadBuildMac4/kicad/pcbnew/kicad_plugin.cpp : FootprintEnumerate() : line 1758

This message is repeated a least a dozen of times (target file is changing of course)
Message cannot be copied, sorry.

Were did I miss something ?

You’re not alone! I’ve got the similar errors on 4.0.0-rc1 and rc2.
Tried on a two systems (Windows 10, and Vista).

Example error:
IO_ERROR: http GET command failed
Cannot get/download Zip archive: ‘
for library path: ‘’.
Reason: ‘Not found’

When I try to follow the https link in my browser I get a gibhub 404 error.

Has something happened to the git? Was it deleted? Will it return?
Sorry for being git illiterate. I’m very new.

I found this issue:
The linked spreadsheet
seems to mention what moved to which location.

OK, that helped greatly. Thank you!

For record, in cvpcb I went to Preferences --> Footprint Libraries. Removed all Global libraries then used Append with Wizard to add all GitHub libraries and saved them locally on my machine.

I see now that all library paths are pointing locally on my machine rather than the repository.
I’m not sure that removing all the libraries and re-adding was an appropriate method to solve the problem. Please let me know if there are better (more professional solutions).

1 Like

rc2 is practically unusable as it is because of this issue! Also with a slow internet connection CvPcb crashes on exit when I have removed some of these nonexisting libraries.
rc3 where this is fixed! anyone? :smile:

Some of libraries were removed (footprints were sorted out into other libraries).
It’s better to use local copy of libraries instead of the “online” that can change without notification.
Please remove online libraries from footprint table and generate new table using
Preferences > Footprint Library Wizard.

Is this a quote from somewhere? Source?

My post from another thread on this forum, sorry for a confusion.

Recommendations for where on local drive (Windows 7) the footprint libraries should be kept so that future installs will not overwrite? I realize I can pick a random folder but wanted to stick with a convention if there is one. Thanks!

I found the following scheme useful (I’m on linux but something similar should work for windows):

Dowload the footprint sources like this:

cd ~
mkdir kicad_sources
cd kicad_sources

Edit /etc/profile.d/ like this:

 # Env var for kicad github plugin
export KIGITHUB=""
# Env var for kicad pcbnew plugins
export KICAD_PATH=/usr/share/kicad
export KI_LOCAL_LIB=$HOME/kicad_sources/library-repos/

(KI_LOCAL_LIB should point to where I downloaded all the footprint repos.)

Then copy your $HOME/.config/kicad/fp-lib-table :

cp $HOME/.config/kicad/fp-lib-table $HOME/.config/kicad/fp-lib-table.github

Edit $HOME/.config/kicad/fp-lib-table $HOME/.config/kicad/fp-lib-table , replacing all “KIGITHUB” with “KI_LOCAL_LIB”. Also replace all “type Github” with “type KiCad”.

Now you can easily swap between online/offline versions by just renaming your “fp-lib-table”.


1 Like

The overarching question I don’t feel like has been very addressed here. That question is, just exactly how do you “upgrade” to a newer footprint library layout? Copying the ‘old’ layouts to a static directory is all fine and good, but what about when you want to refresh THAT directory and make kicad still work with it?

See this FAQ entry:

Including the linked message with procedure that I wrote a while ago.

Especially since anything discussed in the original thread here is out of date. We are on 5.x stable now, not 4.x nightlies…

1 Like