Fighting with V6.0 UI

Two changes: dark theme, and reducing icon size in preferences will get you closer to what you want.

… and schematic editor for the V6 vs PCBNew for V5

Go into preferences and reduce icon size

You are just experiencing a bug we have with high dpi screens which breaks the icon size scaling

2 Likes

Well, one screenshot is a PCB layout, the other screenshot is a schematic. I don’t see how they are comparable.
I’ve plenty of schematics that were created in 5.0 that I’ve imported to 6.0 and they look exactly the same.

V5 used to be: “Point and use”
V6 is: “Point, click to select, then use”, in most cases.
(But not always … )

Eeschema 5’s User Experience was excruciating for new users. Unique amongst ALL other CAD software, in Eeschema 5, clicking an object immediately attached it to the cursor. It was so nonstandard that a chorus of users asked for it to be changed to what it is now – click to select – which is consistent with all other CAD software on earth.

Not saying an option can’t be added. But there was a VERY good reason it was changed.

2 Likes

I’ve done some more “schemating”, and have found the problem … I think.

In kicad5, hovering over an object and then selecting an action (grab/move/etc.), gives focus to the hovered object.

In kicad6 I first have to deselect the previous object, but not always.
For some reason it’s inconsistent.

In 6.0, you have to watch which tool is selected on the right edge.
Pressing ESC after an action resets the tool to “Select”.
It makes sense to me. If you’re drawing wires, why would you want to re-choose that tool for every segment?
Just keep a finger on the ESC key, then you’ll be fine.

As I already pointed out, I’m left handed.

the [esc] key is way over where my hands don’t have to be.

Could you remap ESC to something on the RHS of the keyboard? (I could check but I’d have to get out of bed. :wink:)

The point I’m trying to make is the following:
Please give me back kicad5 UI, or at least a checkbox.

It took a long time to get used to v5, but I was way more efficient than I am now.

Also it distracts.

There is an option “First hotkey selects tool” in common settings. It may not give you exactly v5 behavior but I think it’s closer to what you want.

It doesn’t help you much, but think about all those who are right handed. The [Enter] key is way out of the way, not to mention the [Insert] and [Delete] keys.

Swings and merry-go-rounds?

Thank you, I found that and it does help.

No, the use of those keys are not as inhibitative to your workflow.

(Yet my text comments almost always seem to have an extraneous “enter”)