Eagle import add connection

Hi, after import of an Eagle schematic (kicad 5.1.1), any new connections in the schematic does not carry over to the pcb. Is this a known bug?

What steps do you take to update the PCB?

I have never used Eagle myself, But I seem to remember to have read somewhere that Eagle continuously sync’s the schematics netlist with the PCB.

KiCad is a bit different, and you have to do this explicitly.
In KiCad V5, go to Eeschema, and press [F8] to export the netlist and components to the PCB.

Actually, no, but it is an active action, with its own GUI button in the 5.1 series. I have worked extensively with kicad so I do know how to use that, switched from eagle three years ago. (Been using nightly until 5.0 was released)

Creation was slightly more complicated than I remembered to write: import Eagle project and save as kicad project. Create new kicad project and append schematic from two subsheets of the Eagle-kicad conversion on disk.

Delete one connection of the now copied schematic and redraw it. All other connections transfer to pcbnew, except the one I just created.

Does closing and re-opening the schematic fix it? If so, that may be the result of https://bugs.launchpad.net/kicad/+bug/1824764

Could also be the “kicad adds strange timestamps on eagle import” bug. The one we hunted down in Before giving up on Kicad one last attempt: ERC misery (and spawned a few bug reports in the process.)

@Seth_h Closing and re-opening does add a few connections, but not all. Also, I do get the dialog that is mentioned in the bug report.

@Rene_Poschl All time stamps are eight-digit hex, I believe

I’ll wait for 5.1.2 and see.

I have the same kind of issue today. I have imported an Eagle project, and after tuning everything to correct the project dependencies to existing Kicad symbols and footprints, there are ratsnets missing.
I can verify in the schamatic that 2 points are actyally connected using the net highlighting tool (top right). As the components pins are not highlighted, I can also verify using G command that moving one part actually moves with the connected nets.
Save the schematic, import it to PCB: still no ratsnets between the pins I have just verified.
Using 5.1.0 on Windows 10.


Save, close kicad completely and restart should be a workaround.

I have not had any problems since upgrading to 5.1.2

1 Like


Thanks for your reply.
I can’t be positive about it, but I restarted Kicad a few times, no changes. But I’m not sure I exit Kicad completely. I closed the files for sure, but maybe not the main window.

As for 5.1.2, I checked the official version, and it’s still 5.1.0 (the one I’m using). Is 5.1.2 a nightly build?



The release has been tagged and is available on some OS, I do not know when Windows release appears.

Windows builds are available here https://kicad-downloads.s3.cern.ch/index.html?prefix=windows/stable/

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.