Does V5 have to overwrite on install?


#41

Rather

“C:\Program Files\kicad\bin\kicad.exe”

(To start kicad v4, not v5).


#42

Thanks, good catch!


#43

Why \Documents\ in the KICAD_CONFIG_HOME path, while the line just above indicates AppData\Roaming\kicad5 ? It would probably work, but having the config file in the AppData\Roaming\ directory looks more consistent with the previous version.


#44

You can put the config folder wherever you like… :slight_smile: Personally I find \Documents easier to access.

I can confirm the procedure works, I just tried it.


#45

I understand, but in that case don’t indicate in the previous section (4) to optionally copy the "v4 settings directory’ to C:\Users\MyUserName\AppData\Roaming\kicad5. Or I miss something.


#46

Oh I see, I copied some text from eeliks doc, hence the discrepancy.


#47

Sorry to bother, but I couldn’t make the v5 shortcut working here (Win7 / 32 bits). Maybe the escape characters ^ and the numerous quotes are the cause of the failure A batch file may work (not tested), but anyway, I finally set KICAD_CONFIG_HOME with the Windows GUI (I set it as a System Variable, not a User Variable), and used the default v5 generated shortcut. As the v4 totally ignores KICAD_CONFIG_HOME, it uses its own former config directory.


#48

I originally tested the things in the document on XP, I should try with my new laptop with Win10. There can of course be some plain bugs in the document.


#49

Some text editor has apparently replaced simple quote marks with wrong kind of quote marks. It took a while to find the bug…


#50

I copied that from your Google document… it seems the forum software automatically converted the quotes in some cases.

In my text editor (PSPad) it displays ok (0x22), when pasted into the forum post it displays unicode open/close quotes (0x201C/$201D).

Edit: I updated the post and it shows the correct quotes, and copy/paste gives the correct quotes in the editors I tried (PSPad, LibreOffice).


#51

That’s fine until v6 comes along and you want to run v5 with v6…


#52

True. Thanks for editing your post. It now works flawlessly I also modified the shortcut icon (it was displaying the cmd.exe icon) to stick with the former KiCad 5 icon.


#53

Good idea! It’s a bit confusing with the DOS window. It would be much nicer if there was a command line argument to set the CONFIG_HOME.

I edited my post to remove the optional “copy v4 setup” step. I think that will cause too many problems.


#54

Hey, another PSPad user! Yay!


#55

Thanks @eelik and @bobc it works flawlessly, I used the standard BAT file syntax as follow, without problems.

SET KICAD_CONFIG_HOME=C:\Users\UserName\AppData\Roaming\KiCad_5
START /d "C:\Program Files\KiCad_5\bin\" kicad.exe 

Now I have a question, is it safe to point the KiCad5 paths to the same paths KISYS3DMOD and KISYSMOD of KiCad4, or should I work with a copy ?


#56

Is the idea to use KiCad v5 with v4 libraries?


#57

Not the standard libraries, but I would like to reuse the libraries that I’ve created in the past, but at the moment I’m not planning on migrating all my old projects to V5, therefore they may need to be used with V4.


#58

Your own libraries can be used with V5. The library format has not changed. The footprint format has been improved.

Main differences in pcbnew:
-V5 accepts rounded rectangle pads
-V5 accepts arbitrary shaped pads

Main difference in eeschema
-Now the symbol name is preceded by its library name


#59

And to make it completely clear: all footprints made for v4 can be used in v5 as they are.

Board (pcb layout) files made for v4 can be used in v5 as they are. Footprints used in a project must be added to a fp-lib-table. KiCad configuration has the global fp-lib-table where the footprints can be added if they are not there already. Old projects have their own fp-lib-tables and if the footprints have been added there and exist in the same location as they did, the projects work completely.

Schematic symbols made for v4 can be used in v5 as they are after they have been added to a sym-lib-table which is new in v5, but schematic files made in v4 can’t be used in v5 without migration. The schematic and symbol file formats will be changed for v6 and then the old symbols probably won’t work anymore.


#60

@pedro @eelik Thanks a lot guys, now it is clear how it should work.