CvPCB for association



First time userfor KiCad.v4.0.7
When I run CvPCB, it takes over 10 minutes for CvPCB to return.
And it always return with error as shown below:


You have setup kicad to download footprint data directly from github on demand (github plugin)

If you are behind a proxy or if you have no internet connection, this will not work.

Because for v4 the libs are split between many repos, it would be too much work to directly download the libs from github. But luckily you can download the libs packaged directly from:
In the future this will be easier via the new official lib download page. Or on the site (currently down)

If you are not behind a proxy you can also follow this tutorial:

It is anyways a better idea to run local libs. (And because the old repos will no longer receive updates anyways there is no reason to keep them setup to be downloaded on demand.)


When I installed KiCad 4.0.7, I selected all components to install and I believe this included all the sch, footprint libraries. Is the libraries the CvPCB calls includes additional libraries? What is the different between what KiCad already installed and the items in github?
There is a share\kicad\ directory within KiCad that has libraries already.
Is there a way to turn off accessing github libraries whenever I run CvPCB. The CvPCB always stalled here for over 10 min.


I might have not been clear enough. The kicad 4.x installers (for most operating systems) do not include local footprint libs. They setup your kicad to use the github plugin. The use of this plugin means that kicad will download footprint libs on demand. (They are downloaded to a temporary location. They might even only reside in volatile memory [RAM])

Yes setup local libs as i suggested in my previous post. (I listed 3 ways how to get local libs)


OK, I probably need to understand all the KiCad structure and terminologies…it was mentioned that kicad 4.x installer doesn’t include local footprint, but I checked the share/kicad/modules directory, there are many .pretty folder located there.
Aren’t these consider the local footprints.


Well it seems kicad stable installers for windows (And maybe other operating systems) include the footprint files but setup kicad to use the github plugin. You can simply remove all github libs and add the local libs by using pcb_new->preferences->footprint library manager


before i remove all libraries in my Global libraries and install a fresh lib from the github plugin. There is something strange after i run CvPCB.
I did verify that the kicad installation place many footprint and sch symbol lib at Program_files/kicad/ share/kicad/ .
But from CvPCB Window, all the library on the left-side window doesn’t show any footprint on the right hand side window.
Did I forget to map any path .
I have check the Preference>Configure Path and they looks OK:


I think you should read the documentation. CvPcb does filter the results according to your filter selection and the symbol at hand.
Here my FAQ entry that explains this and a few other options of how to assign footprints to symbols. (Click on the title to get to the post, click somewhere on the top right corner to read it here.)


You should rather open pcbnew (the board editor) and there Preferences->Footprint Libraries Manager and there add DHPC.pretty with Append with Wizard. You can also add a path to C:\tomc\KiCad\libraries\ in Path Configuration and use that as the base if you write the Library Path manually without the wizard: ${DHPC}\DHPC.pretty. But setting paths with Path Configuration does nothing by itself for the footprint libraries, you need to use pcbnew Footprint Libraries Manager.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.