Can't generate board outline in 3D view

I’m tinkering with a layout in PcbNew. When I try to render a 3D view of the layout I get this error message:

IO_ERROR: Unable to find the next boundary with an endpoint of(xxx, yyy).
Edit Edge.Cuts perimeter grahpics, make continuous polygons each from C:/Jenkins/workspace/windows-kicad-msys2-stable/src/kicad-4.0.1/pcbnew/specctra.cpp : ThrowIOError() : line 144
Unable to calculate the board outlines.
Therefore use the board boundary box.

My first take on this was that I simply missed connecting the board perimeter, but I get this message no matter how I draw the board outline. What’s causing this error?


Usually this is because the outline must be connected in the exactly continuous points. Use an appropriated grid to draw the board outline.

The start/end segments must be exact in the same coordinate point.
Please have a look at this issue:

Hm… you were spot on. As I stated, I thought I had a enclosed board outline… Apparently not. :flushed:

Set the grid to the biggest you can, while still being able to keep the accuracy of the outline - it’s easier to get the coordinates to match when there is a lot of ‘space’ between the snap-to-grid points available to the mouse pointer :wink:


Yet an other thing I’d like to ask regarding 3D rendering.

When I do the ‘view 3D’ thing in Pcbnew all solder holes that are connected to my ground zone have a copper cross over the hole, on the grounded side of the board. Is this merely a 3D rendering thing or is it something I’ve done wrong?


You should always check your design looking in the generated gerbers. The cross in the holes from a zone sounds ok. The 3d-viewer (may? or may not?) remove the copper in the holes. There is an option called “Show holes in zones”. Try select that option.

Ah! Yes that did away with the crossed (grounded) pads.

Thanks for the info, and for having patience with a newbie. :blush:

Hello, I get the same message with an outline imported from dxf. I connected all segments to a polyline in LibreCAD before importing. I also checked in Inskape, it fills so it’s continuous. Still KiCAD disagrees. Any ideas?

Run drc, it will tell you exactly where the issue is.

1 Like

It doesn’t list any errors. Should I check any options?

What is your kicad version?

Version: (5.0.2)-1, release build

I believe DRC option to check for outline integrity was new in 5.1, you should update.

1 Like

Thanks, I did update and it shows. Funny thing it was two internal arcs that were causing the problem. I was focusing on the outlline and couldn’t imagine them being the problem…

1 Like