Board2Pdf issues with KiCad V7

Big advocate for the Board2Pdf plugin which created some great results with the V6 release of KiCad. I have just tried running this for the first time on the V7 release and the plugin launches and begins to run but gets stuck at the started plotting stage… Is there a known compatibility issue with the plugin and V7?


Board2Pdf is in test mode

I’m glad that you like the plugin! The latest version in PCM (v0.7) doesn’t work with V7. If you install the latest version (v1.0) manually from the master branch in the repository, it works with V7.

I’m currently on vacation, but I can push a new version to the PCM next week.


We’ll wait. Thank you! :slightly_smiling_face:

Thanks for the info Albin! i have just tried installing manually from the master branch but seem to be having some issues with dependencies, Will hold off until it has been pushed to PCM.


It’s now available in PCM.

Unfortunately this version does require a dependency. This was done in order to increase the speed. It’s now about 10 times faster. Instruction on how to install the dependency can be found in the Wiki - Install dependencies.

Release information of the new version was just published: Board2Pdf v1.1 released in PCM

1 Like

Thanks Albin, have just installed through PCM and installed the dependency through the KiCad cmd prompt with no issues and all works well. Must say it is also a lot quicker! thanks for your help!

Happy to hear that it works for you!

Another plugin has been updated for version 7

1 Like

Trying to run Board2Pdf on Linux (Manjaro), FlatPak install as the KiCad download page suggests. The Board2Pdf wiki tells me

Board2Pdf requires PyMuPDF as a dependency. It’s recommended to install pdfCropMargins which includes PyMuPDF as well as some other useful pdf tools. You can install it with python -m pip install --upgrade pdfCropMargins This command must be run from the KiCad Command Prompt. Not from your default terminal or from the Scripting Console within the PCB Editor.

But I cannot find a “KiCad Command Prompt” anywhere. I can get Board2Pdf installed, but nothing really works. I can enable templates, but I cannot disable any. The enabled and disabled layer lists are empty.

My first time trying to use this program, not sure if these are me-issues, KiCad V7-issues, Board2Pdf issues or Linux issues. Anyone got this stuff working under Linux?

(I just wish I could export a nice PNG “screenshot” like from the schematic editor. Such a hassle to get simple views of a board!)

I’ve recently learned that FlatPak installations (or any Linux installation for that matter) doesn’t have a KiCad Command Prompt. I will update the instructions on how to install PyMuPDF in Linux.

However, from what I’ve heard its complicated to install python libraries in FlatPak installations. I have no idea how this is done.

To solve this issue as well as other issues, I will soon release a version where the user can choose between PyMuPdf (very fast but requires installation) and PyPDF2 (very slow but can be supplied with the plugin).

I will start working on this tonight. It’s morning here so at earliest I will have some beta in 14 hours or so.