Bad layer data error when exporting Step


#1

Hi there.
I’m getting a error “bad layer data” when I want to export a step file from my board. Could someone explain that error? What’s wrong?
I have a board with rather complex cut-outs. But I also get the error when I delete those…


The 3D-Viewer has no problem with the board.
Any comment would be appreciated. Thanks.
Roy


#2

Could you post the full error message.


#3

Hi.
Sure.
Executing ‘“C:\Program Files\KiCad\bin\kicad2step.exe” --user-origin=“100.000000 x 100.000000” -f -o “C:\Users\debbage.roy\Desktop\TestPCB_2x2-Oslon_Pure_4er.step” “F:\TE\BEREICH\IAE\elektrische_Komponenten\PCBs\Testplatinen\Multi-Testplatine\Multi-TestPCB_SLOTS\TestPCB_2x2-Oslon_Pure_4er-Linear\TestPCB_2x2-Oslon_Pure_4er.kicad_pcb”’
Warning: 12:31:50: * bad layer data
Info: STEP file has been created successfully.


#4

Does the STEP file work?

If that layout is not confidential you probably want to file a bug report over at https://bugs.launchpad.net/kicad and attach it.


#5

Hi.
It says the step file was created successfully, but it’s nowhere to be found… :expressionless:
Yeah, I guess I could send a bug report. I just wanted to ask the experts here. Maybe it’s just me being stupid… lol.


#6

Your “error” literally says that it’s not an error but a warning. You sure you don’t have step file on your desktop?


#7

Nono, it’s alright. Don’t worry. And I doubt you’re stupid. I wouldn’t know what to do with such an error msg either :wink:

On that note, have you checked the export path? (I know you’re not dumb).


#8

Hi. Positive, no step file was created…
I know, that there sometimes is a error with long file paths, thats why I tried saving it to the desktop.


#9

Would you mind to post the file? Even a simplified version with only edge-cuts, if you prefer, could be useful.


#10

TestPCB_2x2-Nichia_E17a-4er.zip (487.9 KB)

Here’s a slightly simplyfied version but still with the same error…
Kind regards!


#11

Which is your version of KiCAD?
It seems that recently has been added a change in kicad_pcb file format…
Double quotes has been added to the internal layer description…
This seems to break the STEP exporter…
comparison example:
OLD standard file format:

  (layers
    (0 F.Cu signal)
    (31 B.Cu signal)
    (32 B.Adhes user)
    (33 F.Adhes user)
    (34 B.Paste user)
    (35 F.Paste user)
    (36 B.SilkS user)
    (37 F.SilkS user)
    (38 B.Mask user)
    (39 F.Mask user)
    (40 Dwgs.User user)
    (41 Cmts.User user)
    (42 Eco1.User user)
    (43 Eco2.User user)
    (44 Edge.Cuts user)
    (45 Margin user)
    (46 B.CrtYd user)
    (47 F.CrtYd user)
    (48 B.Fab user)
    (49 F.Fab user)
  )

and the format in your file:

  (layers
    (0 "F.Cu" signal)
    (31 "B.Cu" signal)
    (32 "B.Adhes" user)
    (33 "F.Adhes" user)
    (34 "B.Paste" user)
    (35 "F.Paste" user)
    (36 "B.SilkS" user)
    (37 "F.SilkS" user)
    (38 "B.Mask" user)
    (39 "F.Mask" user)
    (40 "Dwgs.User" user)
    (41 "Cmts.User" user)
    (42 "Eco1.User" user)
    (43 "Eco2.User" user)
    (44 "Edge.Cuts" user)
    (45 "Margin" user)
    (46 "B.CrtYd" user)
    (47 "F.CrtYd" user)
    (48 "B.Fab" user)
    (49 "F.Fab" user)
  )

#12

Hi.
Interesting.
I’m running a nightly build Version 5.1.0-218-ge90452d0e).
I guess I can try the newest build.
edit: the error remains with yesterdays build (5.1.0-265-g1d2db311b)


#13

I’ve posted a query @ the dev mailing list
https://lists.launchpad.net/kicad-developers/
https://lists.launchpad.net/kicad-developers/msg40143.html


#14

This change was intentional (to allow users to put things like spaces in layer names).

I’ll fix up the STEP exporter…


#15

Thanks, I’ll fix StepUp accordingly.


#16

John Beard beat me to it. :sunglasses:

Should be fixed now.


#17

Thank you for all the support! :slight_smile:


#18

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.