Bad graphics in Fedora OS

I use Fedora OS and I already have installed Kicad’s nightly builds from Copr and also stable releases from Fedora’s repositories. This time, I uninstalled Kicad using the dnf package manager, disabled Copr repos with the following command

sudo dnf copr disable @kicad/kicad

and installed the Kicad package from Fedora’s Updates repository. I belive that’s the most recent stable release. My build infos are:

Application: KiCad
Version: 5.1.5-1.fc30, release build
wxWidgets 3.0.4
libcurl/7.65.3 OpenSSL/1.1.1c-fips zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.20.2 (+libidn2/2.0.5) libssh/0.9.0/openssl/zlib nghttp2/1.38.0
Platform: Linux 5.2.8-200.fc30.x86_64 x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
Boost: 1.69.0
OpenCASCADE Technology: 7.4.0
Curl: 7.65.3
Compiler: GCC 9.2.1 with C++ ABI 1013

Build settings:

I’m having some problems with display, things are rendering very badly. For example:

I know Kicad has way better graphics. I had this problem in the past because the nightly builds I used enabled some build flags that caused the graphics to get like that, and the stable release Kicad package I used back then did not enable them, eliminating the problem. The thing is, this time, I belive I do have the stable release package, and the graphics keep messed up. That would not be a big deal if it didn’t cause problems when I’m running the simulator, ploting simulation data, etc.

My questions are: did I install the most appropriate package, or is there a better one? Is there anyway to fix the graphics?

Thank you all in advance for your time.

The issue is with gtk3 theme not working well with kicad. Kicad switched to gtk3 starting from v5.1 so that’s why you only saw it in nightlies but not in stable previously, but now every linux build is on gtk3.

Solution is to tweak gtk3 settings to use different theme.


I use the same package on multiple fedora machines without trouble. One possible reason could be the use of a translated version as the words will have different length compared to english. (I would generally suggest to use any software in english as it is much easier to get help if everyone is using the same terms)

Thank you very much for your response. Do you think I should report a bug?

You can report it, of course. But I wouldn’t expect swift resolution because issue is with wxwidgets and gtk3 not playing along, not with KiCad per se. GTK3 theme support in general for any linux app is buggy as hell, has always been and isn’t getting fixed to my knowledge.

Thanks for your reply. I switched the language to English and the rendering is still bad. Could you tell me which Fedora flavor do you use? What about your theme, which one is it?

I use the cinnamon spin and have no clue what you mean with theme so i guess whatever the default is (If it even applies to cinnamon).

This may also give a hint: Tooltips show white text on white background.

I was thinking about trying a new desktop environment anyway, so I switched to Cinnamon (and I’m enjoying it).

Dark themes still don’t work well, it keeps just like the printscreen I uploaded in the original post. Light themes, though, display very well.

But the simulator screen isn’t 100% yet. One of the problems is that I have to resize the window to refresh the graphs. Is anybody else having this issue?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.