Altium (via Gerber) to Pcbnew

I have Gerber files from Altium and I can open those files in Gerber Viewer. Then I exported those files to kicad_pcb so I can edit those files in PcbNew. But When I try to open I am getting an error.

The mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1010,wx containers,compatible with 2.8),
and wxPython used 3.0 (wchar_t,compiler with C++ ABI 1009,wx containers,compatible with 2.8).

Can anyone tell me what should I do to eliminate this error? Or Is there a way that I can open Altium Project?

Any help would be appreciated!
Thank you

This is not a problem of the gerber import. This is a problem with your installation.
(You will get the same error when opening pcbnew for a kicad project.)
What operating system are you using and how did you install kicad.

Also be warned: the gerber viewer to pcb_new export does not really work.
(At least it does not in the stable kicad version i have not checked it under nightly)
Issues i discovered with it:

  • pads are changed to vias (even smd pads)
  • copper zones are not created correctly. (The outline is traced with short tracks instead. No copper zone is created.)
  • in my tests i found no way to get npth holes imported.

Maybe somebody knows of a workaround for all of that.

I edited your title to indicate that you want to import from altium to kicad.

1 Like

Application: kicad
Version: 4.0.5-e0-6337~52~ubuntu16.10.1 release build

I think Installation is fine. I am able to open PCBnew with my other KiCAD projects.

Well, I am able to open Gerber files into PCBnew, now. Not sure what was the problem before. but it is not 100% accessible. I can’t edit/change/save footprints.

Gerbers don’t have information about footprints in them. This information is lost when exporting to gerber.
(Kicad does not even know there is a footprint after you import the gerbers.)


Good to know, That explains the problem I am facing. Thanks.

Just out of curiosity: Did you experience any of the problems i had when i tested it? (See my first post.)
If not could you maybe give a short write up what you did?
(Or does it just not work with gerbers exported by kicad itself?)

And I keep giving you likes so you can keep doing that :slight_smile:
We need more ‘likers’ around here. :kissing_heart:

1 Like

When I tried to export Gerber files to .kicad_pcb it worked, but I had to manually change its extension to .kicad_pcb to open it with pcbnew. Also, when I tried to export it asked me about copper layer count (16 layers was maximum). Besides that It looks like working.


There are a number of additional ways you can about this that come to mind:

  1. use to convert the gerber into a gEDA PCB format footprint that can then be imported into kicad as a footprint element. The same issues apply with translate2geda having to guess what features are pins or pads or tracks. It may do a better job, or worse, than gerber viewer.

  2. there is a version of the gEDA project’s gerber viewer, gerbv, that can export a gerber as dxf, which may give better results if you can then import dxf:

  3. import the altium project to a kicad compatible format, using:

  4. import the altium project to a gEDA compatible format, using: then export to kicad from pcb-rnd, a fork of gEDA’s PCB layout editor which supports kicad import/export:

See also: Import Gerber into a non routing layer as template