After upgrade to Kicad 7 all system libraries are lost

Just delete or rename those files and when you start the application it will go through the first run initialisation and you should accept the default, which is to use the default system libraries. You’ll have to re-add any personal libraries you had.

Yes, that is what I wrote in that other thread 3 days ago.
So now I’m a bit confused about what WolfgangDomroese has and what he wants.

Sorry - seems I do not describe the problem correctly. I

  • rename the folder /Users/wolfgangdomroese/Library/Preferences/kicad/7.0 to /7.0_modified
  • startKiCad it shows
  • open a project and start Schematic Editor it shows
  • no Library available. Looking at Symbol Libraries Manager it shows this very old list:
  • The only way to get KiCad work ist to maualy edit the /Users/wolfgangdomroese/Library/Preferences/kicad/7.0/sym-lib-table
    BUT the entries in this list do not correspond to the symbol libraries available in the package.
    Therefore I want to recreate…


  • I tried to only rename sym-table-list in directory 7.0
  • I renamed old config-folders in same directora:

The problem still remains. I do not know, where this damned old sym-table-list must be deleted…

Can you verify (and report) whether the symbol an footprint libraries themselves for KiCad V7 are installed at all?

I am not sure what KiCad does, when the libraries for the same version are not installed. It may attempt to use older libraries if it can see those. (But it seems unlikely). Another possibility is some kind of error with the packaging, but then we would probably have more complaints from people with your OS.

Well, the libraries are installed as I showed in the thread mentioned above. Thats why I get it to work maunualy with

  • replace “KICAD_SYMBOL_DIR” by “KICAD7_SYMBOL_DIR” and replacing the type.
    BUT the list does not correspond to the libraries in the package.
    Some libraries in the package are not in the list (I do not know how many) and some libraries in the list are not in the package.

I’m a bit over my limit here. When threads get longer and have too many details I can’t keep it organized in my head anymore.

It seems you had v5.1 installed at some point but it was not completely removed. There are probably template files for the two tables which are still on your system. Search for the filenames sym-lib-table and fp-lib-table anywhere on your filesystem which have the old format and rename or delete them.

Then rename or delete the entire preferences directory /Users/wolfgangdomroese/Library/Preferences/kicad, then reinstall v7.0 from package.

1 Like

Oh -thanks! I got it. But for all, who get the same problems:
It’s not an old sym-lib-table. There was no one else on the system. I had to delete all library files in Library->ApplicationSupport/Kicad and user/Library/ApplicationSupport/Kicad.

I don’t know why the hell KiCad was looking for those files…

1 Like

Well I am only superficially acquainted with the Apple packages so hopefully the packager can explain what happened and why you had the old format libraries.

If you don’t mind I would like to merge this thread with the original one so that it becomes a continuous story.

Please combine the threads.


I had the same problem:

  • After upgrading to v7, no more access to any component or footprint because of a directory error.
  • My configuration : Kicad 7.0.1 with Mac Os 13.2.1 on a 2018 MacBook Air

What worked:

  • Rename (or delete) the Kicad folders located in: Library/ApplicationSupport/Kicad and ~/Library/ApplicationSupport/Kicad
  • Rename (or delete) the Kicad folder located in: ~/Library/Preferences/Kicad/
  • Accept the default settings at first launch

Thank you all for your involvement in the KiCad project!

French / Français


J’ai eu le même problème :

  • Après mise à jour en v7, plus accès à aucun composant ni empreinte à cause d’une erreur de chemin d’accès aux dossiers.

Ma configuration :

  • MacBook Air 2018
  • Mac Os 13.2.1
  • Kicad 7.0.1

Ce qui a fonctionné :

  • Renommer (ou supprimer) les dossiers Kicad situés dans : Library/ApplicationSupport/Kicad et ~/Library/ApplicationSupport/Kicad
  • Renommer (ou supprimer) le dossier Kicad situé dans : ~/Library/Preferences/Kicad/
  • Accepter les réglages par défaut au premier lancement

Merci à tous pour votre implication dans le projet KiCad !