Adding footprint libs

How do I add the footprints which come with the nightly PPA on linux?
I can add them one folder at a time, but that will take a while of clicking around… is there a way to add the whole folder of folders?
holding modifier keys doesn’t allow me to add all folders in /usr/shar/kicad-nightly/modules

If you have installed the libraries from the (Ubuntu etc.) PPA together with the KiCad application at the same time, you should have got the dialogs in the first run which ask what to do with library tables. The nightlies should be configured so that the default option to copy the default library tables is OK and as the result you should get a fully working library configuration.

If there’s some problem you can go to ~/.config/kicad/5.99/ and delete the fp-lib-table. Then start KiCad and pcbnew, and it should ask again.

Another option is to check if there’s fp-lib-table in /usr/share/kicad-nightly/modules/ and copy it to ~/.config/kicad/5.99/.

Yet another way is to use the file dialog which you apparently used. It should accept Shift and Ctrl modifier keys + mouse click, just like in normal file browsers on Linux and Windows. If that doesn’t work it’s a bug.

Copy default is greyed out

As I wrote, modifier keys to multi select don’t work in that window for adding the footprint directories. It’s a bug.

You can select another “global footprint library table file”: click the load button (the file is currently None). Navigate to the main footprint folder and see if you find fp-lib-table there.

EDIT: correction: it’s packaged so that the fp-lib-table should be in /usr/share/kicad-nightly/template/.

And if all of that does not work you can actually add multiple libs at a time with the library management tool. Use the button for browsing for libs to add, and in the file browser like tool that opens you can use the shift and control keys for multi selection.

More details see Library management in KiCad version 5 (Section Adding a library to a library table) Be aware that the graphical interface might have changed slightly but the general functionality is still the same.

That doesn’t work and seems to be a bug. It has worked previously. It’s probably platform dependent. I’m trying with Kubuntu now.

Yes you are right this is broken in current nightly. Is there already a bug report for this?

I haven’t look at the issue database yet. I’ll see to it and try with different distros.


EDIT2: This was originally a missing feature and was immediately fixed, but then it became a platform dependent problem: the feature requires wxWidgets >=3.1.4 which all Linux distros don’t have. See the linked issue.

EDIT3: workaround (or even an easier way to add a bunch of .pretty folders): select the upper level folder and all .pretty subfolders are added automatically. Not obvious, though.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.