Add default libraries to library table

I just reinstalled my OS and wanted to get KiCAD up and running. I installed the program but forgot the libraries. When I tried opening a project, it asked what I wanted to do for the global library table, and I selected to leave it empty since the recommended option, “Copy default global library table” was greyed out.

Now I have the libraries installed and I want KiCAD to recognize them. What’s the easiest way to do that? I’d like to delete whatever program configuration files exist and let KiCAD pop up the same dialogue, but I can’t find where the config files are located. I’m also open to other options, I just want the quickest possible solution.


Read the reset to default section of Library management in KiCad version 5

Ok, that’s done. I now have the popup again. But the option to copy the default global symbol library table is still greyed out. Any idea why?

Because this specific question comes up quite often I wrote a short FAQ article: Where are the configuration files (settings, library tables)?

That means that you do not have the library stuff installed or that the installer did not add the default library tables where kicad can find them.

If you have the libraries installed (or at least have the libraries somewhere locally) then you can either add them manually (see the article linked above) or download the library tables from and and copy them to your config directory. (you might need to point the path variables to the correct location. Again see my faq article.)

Got it. Installing kicad-libraries for whatever reason didn’t suggest or install the actual library packages. Thanks for the help!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.