5.99 and zone boundaries

Before I forget: I’m running the latest Kicad (nightly build 21-02-07), windows 10, 64 bits, version running in a virtual machin on Ubuntu 20.04.
I’m wondering about the zone boundaries feature. In the left menu, I have 3 choices instead of 2 in 5.1.9. One is showing only tracks on all the selected layers
One is showing the zones, with some transparency that can be preset the right menu.
And one showing the zone boundaries only.
What is this one doing?
Actually it’s drawing myriads of horizontal line which renders the whole design quite confusing. At first i thought these were traces.
And if I choose the filled zone setting, I still get the zone boundaries by transparency.
Some screenshots to illustrate what I’m saying.

  1. The original design (made with 5.1.9, and accessed with 5.99. No problem here.

  1. Showing the zones, especially the zone with the currently selected layer. No transparency, so it’s of limited interest, but it can be useful sometimes to detect when some zones are “islands” and therefore not connected. No problem in this one either.

  1. The zones outline only. There are myriads of horizontal lines showing up. It looks like horizontal lines are generated at every hole, which makes an unreadable PCB because all these lines look like tracks. This is obvious in non-signal (e.g. ground or vcc plane) where there is one single plane punched with many holes.

  1. In zone mode, it is still drawing the outline of zones. This one could be useful if stripped from the zone outlines.


I don’t know why you say that, because the same 3 are in 5.1.

To be honest I don’t know why this option even is in the toolbar. It shows the internal constituency of the zones, the technical implementation. IMO it’s pretty useless for normal work. The horizontal lines show how the gerber copper areas are generated – each area is one big polygon which surrounds every hole in it separatly, so the polygon outline goes along those lines.


Sorry, you’re right. I simply never noticed.
I agree that it’s useless, at least for me. But in this case, it should be removed when looking at all the layers with transparency. Solid layer work, display without copper fill works, so it wuld be nice to get the outline out of the semi-tansparent display.


Please do not go inventing your own date format. I had been staring at your string of numbers before I realized it was a date. ISO_8601 is (as far as I know) the only date format that has a logical order (From big to small numbers) and it specifically states that years must be (at least) 4 digits wide to avoid ambiguity. Combine that with worldwide use of this forum (and other internet stuff) and that almost any order of date items is used makes a bit of ambiguity a clear drop in muddy waters.

As eelik wrote, It has been like this for a long time, and I also do not know why it would be usefull to show the internal zone geometry. However, with the setting “Show filled areas of Zones” I never see the internal geometry, regardless of transparency settings.


Sorry for the date. 2021-02-07 is the right date (downloaded this morning).
That said, to be accurate, if I use “show filled areas in zones”, I get the picture I posted above (the last one) which looks very confusing. I thought these were traces. The same setting but with pushing the transparency cursor to fully opaque results in the second picture, the red one.

As I wrote before: With the “Show filled areas of zones” setting, I do not see anything of the internal geometry. Not even with half translucent zones:

Maybe this can be influenced by a setting somewhere in the preferences.
If I change to the: “Show solid areas of zones in outline mode”, then it does show the internal geometry, but with the same transparency settings as the “zone” setting in the “appearance manager” (on the right of the screen).

Ok, I will do a similar setup, in order to show various settings. I will call them options 1, 2, 3, fom the top most, middle and bottom most icon.

Here is what I get with option 1 (you can verify in the left menu the option I am talking about). You can notice that I have the various layers filled and half trnaslucent, but I also get the outlines and therefore this one is not very useful.
The mouse hover label is “Show filled areas of zones”, and the action corresponds to what it says except for the outlines that just make the layout confusing.

Option 2

This one can be used because there are no extra graphics.
The hover label is “Show only the zone boundaries”, and it corresponds to what it does.

Option 3

The hover label is “Show solid areas of zones in outline mode” which seems to correspond to what it does, but it’s useless, at least to me.

That’s about it for today!


Are you using non-accelerated fallback graphics mode?

Yup, this is an artifact caused by the fallback renderer, unfortunately there is no easy fix. I recommend using the accelerated graphics mode if you can.

I’m running Kicad 5.99 on a virtual machine. Is it possible to have accelerated graphics in that case? I have tried to enable it, it says I need openGL 2.1 or later. I tried to find openGL, and all the link point to NVidia. I have only on board graphics because I don’t care much about speed. Does it matter? What will happen if I use a NVidia-related openGL? Or is there a recommended openGL to be used in a virtual machine environment?


  • Home made PC without PCI graphic board. I think the graphics are from Intel.
  • Linux Ubuntu 20.04
  • Windows 10 as a guest. Mostly dedicated to Kicad (I mean, no other software can interfere, I have installed only the minimum, opera browser, openshell, and that’s about it.

What VM software are you using? You may be able to enable graphics acceleration in the VM (i.e. GPU virtualization) so that OpenGL will work. In VirtualBox, for example:

KiCad uses OpenGL for accelerated graphics in the board and schematic editor, which is normally used for 3D programs (even though we use it for the 2D drawing in KiCad) so you will see this called “3D Acceleration” here.

Thanks, it worked at once (I’m using virtualbox).
Now I have noticed 2 odd things.

  1. In accelerated graphics mode, the zoom behavior is erratic.
    Usually there are 2 modes:
  • A mode that forces zoom at the center. The current position of the cursor is moved to the center of the PCB display space.
  • A mode that doesn’t change the cursor position, and that zooms around the cursor.
    I have set the accelerated graphics, and the zoom is neither of these modes. It keeps the X axis on the cursor and moves Y.
    In the attached video, I move the mouse roulette one step at a time (it’s a logitech with a step mode). Beside this, there seems to be another problem, but it might be related (fixing one may fix the other). You can notice that sometimes the steps are very small, which is fine with me because that was something I didn’t like previously, the zoom steps are too big. But sometimes, with the same step on the mouse, the zoom moves quite a lot.
  1. A funny thing:
    As I noticed this bug with the zoom, I wanted to be sure that there is no such bug without graphic acceleration. So I set the graphics back to normal, and this time the display works fine (without zone outline strokes). Well, I’m not going to complain that it works, but I thought it would be worth mentioning.

I thought the legacy renderer was going to be phased out / removed at some time not too far into the future. It’s not an option anymore on my Linux box.

I also accidentally bumped into an issue report on gitlab for this issue:

Yeah, it is technically not very feasible to fix the issue as long as we are using Cairo. So our options are to ignore it, switch to a different software renderer, or stop supporting software rendering. The third option is not likely to happen (anytime soon) just because we still have some users who want to be able to use KiCad on ancient hardware, and as long as they are running a relatively modern OS on that ancient hardware, we want it to be possible.


what GPU do you have on the host machine? I guess this depends on how well VBOX does passthrough or whether it does software rendering. Have you installed the guest vbox drivers?

If it is software rendering this could explain what you are seeing… it’s not so much erratic but because the framerate and process rate is slower it is more influenced why when you provide an input and thus would appear erratic .


As for the GPU, I don’t know. I’m using an ASUS mini ITX motherboard, and I don’t have any
other graphic board, everything is on board.

If it is software rendering this could explain what you are seeing… it’s not so much erratic but because the framerate and process rate is slower it is more influenced why when you provide an input and thus would appear erratic .

I was moving very slowly, one mouse mechanical step at a time. Sometimes (from about 4 second in the video), the changes correspond to my wheel movement rate. And sometimes I get the whole screen downscaled by a factor of 2.
And this does not explain why the mous position change happens. I’m in the mode where everything should be scaled around the cursor, and the position of the cursor itself should not move at all inside of the drawing. In the video above, you can notice that I’m starting to zoom outside of the drawing frame, and when I zoom, only Y changes. Originally at anout 1/10 of the total height (letter A), it moves to a position close to alignment with board’s upper border (letter B).
X doesn’t changed, but this corresponds to my setting.

Hi Roboya,

The option “Show solid area of zones in outline mode” is shown below

The extra lines are mostly part of the KiCad algorithms and do not serve a major functional purpose.

You can use the other two options for viewing the copper pour with clearance and just the outline of the copper pour without clearance.

1 Like

Hello Amit!

Thanks for you reply!
It looks like you missed the point. Please look at message 7, first picture. What I was saying is that in semi-transparent mode, it shows the zone borders, and I think it shouldn’t. You can notice on the left menu that the zone mode is activated, and therefore the outline shouldn’t be shown.

Does anyone actually use this setting? I wonder if it is really needed anymore? It seems to cause more confusion to users in my experience.

Hi roboya,

Those lines should not be visible in the zone. It might be a bug since we are using the 5.99 version which is under development. Either you can download the latest version available on the KiCad website or can update the shape by clicking on the Options > Properties > Ok. It will directly update the shape or zone. Thank You!