5.1.10 3 minute library load (SOLVED)

TL:DR : SOLVED -> Here’s the fix

Using 5.1.10, Win 10-64 on FX8350, Hardware GFX switched on (GTX980), 16GB RAM and an SSD.

Every time I click on something footprint library related the loading bar pops up for the footprint library and proceeds to take around 3 minutes to load the library EVERY TIME.

This is a base install of Kicad and I didnt even load in the updated libraries yet.

To iterate my point of there being some ACTUAL issue, here :
Last week I used a different computer in the shape of a Dual-core Athlon 64 with Intel graphics and a 7200 RPM Plate drive. The libraries generally took 20-30 seconds to load and would only do this once at the start. This is a PC that hangs for 5 minutes trying to load CPU-Z and its outperforming my rig on this software. What can I do to solve this?

This is the third PCB software I’ve tried now and I am literally smashing my brains against a wall. The footprint library and all its function is a total mess. Its like some Hydra-Kraken flailing helplessly in a pit of lava (too many heads and too many arms and none if it is really working together).

This software needs a massive overhaul in the direction of STREAMLINING. But I’d settle for a fix on this software breaking slowness issue. Its un-usable if I want to do any actual work.

I am just trying to create some artwork. I dont even need the entire Schematic side of it; I just need a mask. Will it be quicker to just use MS Paint?

EDIT : Im using only the PCB design portion of the software and associated libraries.

As I attempted to discover the answer I came across this thread

What this thread spells out is that the slow loading of Kicad Library is more related to crappy internet speed than crappy computer specs. Release its hold on Links to GITHUB and suddenly loading is super-fast…apparently. I shall try this and report.

Has a passmark rating of over 6000

Which is still twice as fast as the i7-870 that I have.

I’ve been “plagued” by footprint library loading (caching?) times of around 25s (from SSD) but only (mostly?) after switching projects, and the first time footprints get loaded during a KiCad session.

3 minutes is excessive.

Recently I had to switch to the nightly version of KiCad V5.1.x because of a conflict which prevented me from running both KiCad V5.1.x and V5.99
deb http://ppa.launchpad.net/js-reynaud/kicad-5-nightly/ubuntu focal main

That Js-Reynaud version has much quicker library loading times. Around 5s for me. This should have been fixed in KiCad V5.1.11, and that version is apparently already released for windows and I expect the offical announcement “soon”.

I tried the fix I posted above from user @BlackCoffee

I created a folder in my user directory called “GitHubNullifier” (You can call it what you like) and then under Kicad main program -> Preferences -> Configure Paths I changed the KiGitHub Environment Variable to point to the folder I created.

Restarted the program and…

The Library loading is now pretty instantaneous (1 second load time).

I’d call this a fix. I’ll report if the problem rears its ugly head or if I was misconstrued about the level of repair.

My parents crappy old PC outperformed mine because they actually have some pretty fast internet which turns out to be the bottleneck of the Footprint library.

Thanks @BlackCoffee

Main task of any PCB design software is to make sure that you make all connections from schematic and no others.

If you want to use it only as graphic editor then don’t be surprised that there are many functions you don’t need or don’t understand their destiny.

1 Like

As an Electronics Engineer I do understand the software and design flow.
I am not sending my files to a manufacturer. I’m making a single sided Dry-film style PCB at home so I can mount some chips to begin prototyping. This is why I dont need the schematic side, as I dont actually have a complete schematic to use. I simply need to mount and power my chips as they are too small for good old fashioned Bread board. My output will be to a printer to produce my artwork on transparent acetate. So you see this should not be such an insurmountable task… it should be simpler, in fact, than the complete process; I’m sure you’d agree.

My issue is not with the usage of the software, it was with the incredibly time consuming task of loading libraries which was not my failing or lack of knowledge of usage but that of the software and its bugs.

The GitHub removal fix solved the problem.

Any PCB software should be perfectly able to create a PCB from the outset and perhaps work backwards to a schematic.
I abandoned the previous two EDA packages because as it transpired, neither of them had ANY support for external footprints!!

Even a test board can have its complete schematic.
Recently I have designed a prototype board to have a place to assemble and check circuits using LVC1G chips.
I even didn’t considered doing it without schematic:

Sorry, but not. Making PCB without schematic is working against software. KiCad should be doing everything it can to not allow you make any connection as such connection is not at schematic.
What you want is possible but it is abnormal use of KiCad.

A bold thesis.

1 Like

My opinion. But with the processes of labels and linking etc in place theres no reason why one cant ‘two-way’ the process. The trouble is that Kicad is a mish-mash of unrelated programs cobbled together. Open-source is great but … too many cooks, man!

This is erroneous design to me. This is software which is geared towards outward manufacturing only. In a streamlined software package there should be no such restriction or force of design flow. I should be able to easily define nets etc within the PCB software and backflow it to a schematic if I wish. That would be good software design.

Also, I can only disagree that this is abnormal use of Kicad given that they include the option to freehand your design if you wish. Why include the Add Part button at all if it goes against the program? That makes no sense :slight_smile: After all, some EDA’s dont have this option at all; it would be against their programs, but Kicad made that distinction, not I.

No, I dont have any usable schematic at this point. I need to try a few different things from the outset so essentially Im working with placeholders for what I could be using. I’m going to have to make several boards over the next few weeks as I actually develope my circuit. I’m literally going to have a whole bunch of unconnected stuff. This will never pass through design viability checks.
I dont even know how to use a MAX11198ATE+ at this point in time but its 3mmx2mm with 16 pins so I need to mount it before I can even begin trying to work it out. You see where I am with this? Im simply not ready for a schematic and the EDA should not be placing a wall in front of me (which is why I chose Kicad… because it doesnt). I’d breadboard the heck outta this but thats not an option :slight_smile: Schematic requirement is like spending 2 hours drawing up a plan about how youre gonna walk to the shop for 5 minutes (in this instance).

To allow to place footprints not needing any connection like mounting holes, fiducials,…

OK. If you don’t want any connections at PCB you don’t need a schematic. You can simply place footprints.
I just supposed that even in such case some standard connections (like decoupling capacitors) can be done on board and not with wires later.

Aye, thats what I’ve got essentially. Ive included caps, timing and power placeholders. Ill produce this on PCB and IO to breadboard for the rest of the circuit development, switching to SMT when components and values etc are decided. Normally this would be plenty to complete a schematic but I’m going to be using a dsPIC33 80 pin flat package. There’s a heck of a lot of stuff in that chip that I don’t even know what pins I’m going to be using yet. I’ve got to mount it first so I can work this stuff out.
In a couple of weeks I’ll be in a position to start creating an actual schematic and then I can begin using the software the ‘intended’ way but first I need to hurdle this minefield of unknowns. I’ve got two chips to work with right now. They took 2 months to arrive from Thailand so if I mess this bit up thats going to be a lot of downtime waiting for a new batch.
Ofc, its nigh-on impossible to account for all usage scenarios within a software package, so I’m not going to gripe too much about the design flow. But that library…damn.

We have placed orders for parts which we got confirmation for September 2022 !!!
It looks that we will have to stop production for may be a half of year. But you have to live off something, and that’s the problem :frowning:

Yep I had that same problem. Most sample parts had a lead time of 364 days :rofl:

I’ll take this opportunity to give kudos to Maxim Integrated who sent me my sample ADC’s from the Philippines in 4 days by first class Air Mail. Inside the package they’d addressed and stamped another package even though that was never going to be seen or used by anyone. They paid for it twice… just in case. I emailed them about footprints. They told me about Ultralibrarian and then Emailed me the footprints anyway. Legendary first class service.

Farnell prices and lead times are crazy mental at the moment. I had to resort to BangGood for capacitors. 4500 0603 capacitors for £12. That’s 90 values of 50 caps each.

But I’m in a lucky position. My livelihood does not depend on this at the moment. I do a repair-all business on the side. Circuits to sashes and everything in between. I’m just a bit anxious about getting on with this project as I’m creating a Next-Gen in an existing semi-niche field in which there has NEVER been a NG advancement. Its a game-changing notion and I can’t understand why the existing experts in the field haven’t put 2 and 2 together on this one. So I’ve got to get it done before someone else realises what’s possible.

If you got an idea you can always ask: ‘why I didn’t got it earlier?’ and ‘why others didn’t got it?’

About 1990 we got two electronic keys from someone with question if we can do something like that or better. One had 16 contacts arranged 4x4 and door lock had 4 contacts contacting row by row in key during inserting. Connections between contacts were a code. Second was looking like modern flash drive ended with 4 pin socket so in door lock there were 4 pin header (raster 2,54). The key shape did not allow it to be inserted otherwise. There were a microcontroller inside.
Thinking how to improve that I invented RFID, made some experiments and found I can made it working. I didn’t know that it already exists :slight_smile:


For me it takes over a minute with oldish hw but with SSD, every time when the footprint libraries need to be reloaded (cache rebuilt). 3 minutes sound excessive. But as was said, using the old (and later removed) git loading feature it may be very long.

Ha. Love it.

This actualy brings rise to the concept of Natural Progression. Logical next steps etc. Upon thinking about why my idea hasn’t been done before, of course the next question is “Is it because its not possible?” and then “Am I missing something??”. I did some pretty extensive research. It feels like a naturally progressive move but a few steps ahead of the curve.
I’d love to talk about it but then I’ll nullify any chance of applying for a patent in the future. If this thing works as I intend or even if it HALF works as I intend then I’ll be set for life, as such. Incredible profit margins in this field. But I won’t lie…it is super ambitious and probably a large enough project for a team of 5 for 12 to 18 months.

Indeed. Our internet went down hard and has been dead for a whole week. So, I was tethering from a 3G Smartphone. Its very slow internet. This is why I experienced such excessive loading times.

I have never even thought about using KiCad with libraries located not at my HDD.

Nor I. This was a default install of 5.1.10.

The KiGitHub environment variable is there by default and I’m not entirely sure that anyone knows why the program attempts to access GitHub continuously. This should blatantly be a configurable and selectable option. I read it is removed in the later builds. The current behaviour baffles me, completely.

This is why I avoided a few particular EDAs. They seemed to require constant connection to some server and you are then uploading your IP to their servers to use their software. What the heck is that about? :smiley: Risky business in my opinion.

I am using 5.1.10 at Windows 7 64 bit (the same install for Win 7 and Win 10) and I don’t remember I need to change where from are libraries.
May be it was something from previous installations. At Win 7 KiCad saves its configuration in C:\Users\{User}\AppData\Roaming\kicad

I use KiCad at PC not connected to internet.

The local libraries all seem intact. In the thread with the fix someone mentioned that upon detecting no GitHub folder, the program is supposed to revert to using some sort of cache, but this was not happening as it should have.

There has been discussion across the forum and GH about the lack of streamlining and accessibility of the local libraries. There seemed to be a lot of confusion about where the original files are stored and where additional files should be kept. I tend to agree; some of the program is distributed across Program Files and some in the users directory. I think my library files live inside the filepath

C:\Program Files\KiCad\share\kicad\library

The lib-tables in the Roaming folder appear to be something akin to a table of contents, although I havent looked extensively. It should all just be in one place, in my opinion. I actually really dont like it when programs jam stuff in my Users directory.