3D step insert bug in Kicad 7

Hi guys, Does anyone facing problem with kicad 7 3d step model? seem that the PCB footprint not load correctly in 3D mode, then I can not adjust the exactly position for 3d step model.

I am not aware of any widespread issues with KiCad 7 3D step models at the moment. However, it’s possible that the issue you’re experiencing is specific to your setup. Let’s see if anyone else is facing the same problem.

Welcome to the forum @woljpro. I have been adding some 3d models to my footprints (in v7), and have had no problems at all. I have added quite a few by just text-editing the footprint file and adding the model at the end, but it is is also easy in the footprint editor properties by adding the model, and tweaking rotations and offsets if needed.

Here, there is no model yet:

So add it:

Hmm, That’s not right:

Just a few rotation/offset adjustments:

I have made a few parts in solidworks, and of course define them so they do not need rotation/offset/scaling, but sometimes you find a model from a manufacturer or a generous person on grabcad, and the adjustments are needed (and easy by clicking the +/- buttons or typing in finer adjustments).

1 Like

Hi @teletypeguy , thanks for your comment. I also can do it with almost component but some time I face this situation, it’s look like the boundary of PCB is not correct:

I have never seen the circuit board that small in the 3d properties editor, and the through holes are not shown either. Looks like you need -90 degrees in X, and some offsets, but yeah that is odd that the full section of the board is not shown.

Can you attach the footprint file here?

Hi eelik, pls see this:
Footprint download

Your footprint looks fine on my system:

Here is the footprint on my system

I’m using Version 7.0.0 on windows

I’m having the same issue on version 7.0.0, Windows 10. 3D models render fine in the 3D Viewer, but not in the footprint properties.

Version info
Application: KiCad PCB Editor x64 on x64

Version: (7.0.0), release build

	wxWidgets 3.2.1
	FreeType 2.12.1
	HarfBuzz 5.0.1
	FontConfig 2.14.1
	libcurl/7.83.1-DEV Schannel zlib/1.2.13

Platform: Windows 10 (build 19045), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
	Date: Feb 12 2023 01:35:19
	wxWidgets: 3.2.1 (wchar_t,wx containers)
	Boost: 1.80.0
	OCC: 7.6.2
	Curl: 7.83.1-DEV
	ngspice: 39
	Compiler: Visual C++ 1934 without C++ ABI

Build settings:

1 Like

I can’t help with this truncated-pcb-in-footprint-properties thing, other than to point out that I don’t see it on my linux kicad, but two windows kicad users have seen it. Any other win users see this? Maybe an actual issue or maybe a config setting somewhere? I can see how this would be frustrating.

The footprint worked OK on Kubuntu, KiCad 7.99, but I didn’t try on Windows yet.

EDIT: I tried on a PC Windows 10 and a laptop Windows 10. The footprint 3D view works OK on both.

Doese anyone get this issue the same? I just face it several times already.

I had the same problem, exactly as you described.
It occured on my notebook.
When I tried to reproduce on my workstation, there was no bug.
Both are Windows 10.
May be it is a graphics driver depending issue?

See Footprint Editor: 3D Models of PCB footprint shrunk (became tiny) - #4 by itsko

This is a bug that happens if the F.CU layer is invisible in the PCB editor (not the footprint editor)


That’s the solution: The F.CU layer makes it.

I would like to mention a difference:
@itsko reports a tiny model shown.
I only have a tiny black block.
See the size compared to the coordinate arrows

with F.CU on it looks like this:

1 Like

I thought I tried everything, restarted computer, reinstalled KiCAD, but I was having the same error as you. The footprint only showed as a small box in 3d preview for the component. I had my Front Copper (F.Cu) layer off. As soon as I turned on F.Cu, the footprint came back for me.

This seems like a bug, as the Footprint should be shown in the 3D preview without the Copper layer turned on in the main board editor.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.