3D new library for Mechanical CAD exporting and enclosure design


#181

Yes

it seems to be in some solidworks format

maybe i can open it in creo

or as you said do my own in freecad (done it once before)

thanks


#182

you can choose the format before downloading it :slight_smile:


#183

opps

so I could

i tried step, wrl, iges
none showed up in kicad.
will open the models in freecad and see if they show up

shows up nicely in freecad
could be scales, and axis, and rotation problem


#184

If you are using the KiCad stable version (version 4) you will need to use the tool StepUp http://sourceforge.net/projects/kicadstepup/ to convert from STEP to WRL properly.

If you want use STEPs directly with KiCad you will have to use KiCad Nightly Builds or wait for KiCad 5.


#185

I have the nigthly

Application: kicad
Version: (2017-01-30 revision 9627f06)-makepkg, release build

I scaled it up to 1000 x,y,z in footprint properties but nothing showed up

tried the wrl file also

nothing shows
same files pops up nicely in freecad


#186

What version of vrml is your file?
I think kicad only supports vrml version 2


#187

If you use KiCad Nightlies, when you preview a STEP model it should show in the preview window. That should be the first step to make sure you are able to load STEPs.
I don’t recommend use WRL files from 3DContentCentral. I recommend use WRL files exported by StepUP tool.

If you can see the STEP model in the KiCad preview but not after add it, then it is a offset model problem.
You will need to center the model using FreeCAD. I guess StepUp tool also can aid on this process.


#188

I don’t see it in the preview either.

2 different versions of step.


#189

Hi @nicholas
would you mind to try with StepUp?
here a link of a video to load and align a 3D model to its footprint directly in FreeCAD
Align 3D model to footprint with kicad StepUp
and the correspondent thread in this forum
forum thread “interactive Align 3D part to footprint”
The STEP model you will export with ksu will be aligned to kicad footprint…
PS an other thing you may have to check is if the footprint .kicad_mod and the pcb .kicad_pcb have the same wrl or step model and parameters
Maurice

EDIT
here a model done with 3d model generator
sot891_1x1_p035.wrl (23.7 KB)
sot891_1x1_p035.step (74.5 KB)

and a version without visible pins
sot891_1x1_p035.wrl (13.4 KB)
sot891_1x1_p035.step (57.4 KB)


#190

I dont mind using step-up, i have used it in the past.

but now i was on another computer and did not have it installed.

i will fix asap

thanks again for helping out


#191

Can you try with other STEP models?
If you are not seeing it in the preview, so something is wrong, probably you do not have the 3D plugins properly installed. Have a look:


#192

are you in windows and do you have utf-8 chars in your 3D path or name?
I noticed that in windows if there are utf-8 chars in the path, then the model is not displayed (in linux is fine)


#193

just plain ascii 7 bits characters in path and filename


#194

I thought there’s a UTF8 problem. If you compile your own, try defeating the fileType() function in plugins/3d/oce/loadmodel.cpp so that it simply reports FMT_STEP. If the STEP model with (non-ASCII) UTF8 characters in the name loads then I know how to fix the problem.


#195

I just added

FormatType fileType( const char* aFileName )
{
    return FMT_STEP;  // test 

but this didn’t solve the prob…

I’m on win 10-64 (working fine in ubuntu)
I tested with utf8 chars in name and/or in folder


#196

Thanks; I need to look through the OCE documentation for clues on how to pass Windows utf16 strings to the open functions.


#197

Can you please try this patch and let me know if it fixes the problem? If it does then I at least have some idea how to get started. Unfortunately I can’t even check if this will compile since I’m not set up to build for Windows. If the problem appears ‘fixed’ I need to do extra work; for example I disabled the fileType() test in this instance.

[edit: first patch was bad; try this one]
step_fname_20170221.patch (1.7 KB)


#198

@maui are you going to be submitting these connector models to the master repo? they look great! Perhaps some of the other connector series can be scripted :wink:


#199

I’ll have a look at adding the kicad naming to at least the picoblades :slight_smile: hopefully more of them, before 4.0.6 :stuck_out_tongue: I think they need a little translation to fit the footprint properly


#200

@Shack and me are working on most common models atm…
we are going to PR SOIC, QFP and QFN…
A lot to do and I’m doing it on some little spare time :wink:
Anyway the MCAD move has finally started to be merged into official repo… :smiley: