3D component packages not displaying

Hello everyone. I recently came across KiCad’s software (in January of this year), and have been absolutely delighted with it. It was a step up from ExpressPCB, and the learning curve was not bad at all–I’m getting very comfortable with it. At the moment, my project schematic is done (including custom parts), and the PCB routing and layout is complete (including custom footprints). Free GERBER files–oh, what can I say?

However…it seems that something has gone wrong with the 3D viewers. One is EEScheema’s ModView (EEScheema -> Component Properties -> Assign Footprint -> Show Footprint in 3D viewer); the other is PCBNew’s 3D Display feature (PCBNew -> View -> 3D Display). Interestingly, PCBNew’s 3D Display works correctly on KiCad’s example projects…but they also aren’t using the default KiCad libraries for anything. However, if I try with my project (or a new project), none of the component packages show up in the 3D viewer. The circuit board and footprints show up just fine, though–almost like KiCad can’t find the WRL file associated with a footprint. I seem to recall component packages working when I installed KiCad, but am not quite sure what has changed. (New users can’t upload pictures, so I can’t attach a screenshot.)

I have added components to a couple KiCad libraries (such as “regul”), but that has nothing to do with 3D packages, AFAIK. All of my custom PCB footprints are in a project library; no 3D packages on any of those. But those SMD capacitors, 1206 SMD resistors…no packages display!

The settings look fine, such as PCBNew’s environment variables (PCBNew -> Preferences -> Library Tables). KISYS3DMOD is specified as “C:\Program Files (x86)\KiCad\share/modules/packages3d”. The backwards slashes might be a problem, but I can’t seem to find a way to change that. Otherwise, the path looks good. (Note that I installed KiCad to “C:\Program Files (x86)\KiCad”)

FWIW, I am running Windows 7 Ultimate x64 on an Intel i3, 32-bit graphics. If anyone need more details to help, I will gladly provide what is needed for a diagnosis. Thanks in advance for any assistance.

would you like to try:
C:/Program Files (x86)/KiCad/share/modules/packages3d/

Yes, I would like to try that…my only problem is that I don’t know how to change those environment variables. Single-clicking, double-clicking, pressing F2, etc. and nothing happens. Do you know how to change those environment variables in PCBNew?

(edit) I’ve checked the Windows system environment variables (right-click My Computer -> Properties -> Advanced system settings -> Advanced -> Environment Variables), and there’s nothing about KiCad in there. I’ve checked the BAT file that the KiCad shortcut goes to, but that doesn’t set the KISYS3DMOD variable. In EEScheema, I can add/remove search paths for libraries (Preferences -> Set Active Libraries), but those aren’t KiCad environment variables.

Any suggestions?

you must add a new variable then…

Tried editing the “KiCad.BAT” file, reversed the slashes on the “SET KICAD=” line, so it reads “SET KICAD=C:/Program Files (x86)/KiCad”, but that didn’t change anything. The slashes still appear both ways in the PCBNew environment variable KISYS3DMOD.

OK, edited KiCad.bat again, adding a line, “SET KISYS3DMOD=C:/Program Files (x86)/KiCad/share/modules/packages3d”. That changes the KISYS3DMOD environment variable in PCBNew, but the 3D packages still don’t display in the 3D viewer. (I tried it with backslashes as well–no change.)

Now what?

You can try add in the end a / after packages3d
I don’t know how to help much more because I am on linux.
Make sure the footprints you are displaying have 3D models setup.

Bingo! Found that KiCad was looking for “…share\modules\packages3d\Capacitors_SMD.3dshapes”. Every single folder in the installed KiCad library doesn’t have the “.3dshapes” suffix on the folder name. Why, I don’t know–but after renaming the folder to add the suffix, now the SMD capacitors are showing up on my project. Somewhere along the line, something changed all the folders–or KiCad started looking somewhere else. Weird.

I dont know about the libraries that kicad proviced since I am using my own.
In that case I think you maybe be using an outdated version of the libraries, since if you check here:

they updated 9 days ago with that new .3dshapes extension name.

That’s very interesting. I didn’t update KiCad by myself, and it worked when I first installed it…something happened along the line. Now I’m a little disappointed at how few items have packages (wait, this is a FREE program!)–but to be fair, I am using a lot of parts that I had to create! Will get the library update, and see what I can do.

And thats why you can contribute to the project :wink:

You may find this interesting:

I was just rummaging through the first link :smile:. Found a few parts there (DO-214, SOT-23-5, SMT pushbutton), but not a TO-263-5. Now I have the delight of re-doing the pin assignments on the SOT-23 for the BC817 transistor. Thanks again for your help.

Hi kcd_DDesign,

the current KiCAD versions fetches the github things from time to time (i think for the footprints every time you start the software and than hit the CvPcb tool but iam not shure…)
the other folders are currently only updated at the install (or winbuilder compile)

so if the lib team decides to change some structures it is likely to fail at your home system - because only the footprints are updated automatically …
(not the 3d packages…)

i had a similar problem to yours some time ago…

if you want to add some footprints or 3d files they are welcome:

(and there are guidlines how the footprints should be designed so that they are ‘consistent’ with the rest of the lib)

sunny greetings

hi everyone, i had the same problem, i could’t see any 3D view of the component from the library. After google a little i found that more people had the same problem but i haven’t found the solution there.

After surf a little in the preferences of kicad i solved it:

-Open kicad, in the main window (no schematic, pcb …) go to preferences>edit paths. A new window pop up showing the variables KICAD_PTEMPLATES, KISYS3DMOD AND KISYSMOD that drive to the nonexistent place c:\msys64\msys64\share\kicad…

For the kicad 64 bit, the correct path is: C:\Program Files\Kicad\share\kicad…

And voila… i can see the 3D components from the standard library.

I hope it help.

and if you are interested in exporting your board in mechanical CAD, you may consider useful this script:

(here some tips for working with 3D objects)