Drag 45 degree mode


#1

For a while I used Vers 4.0.7 with “Canvas Default”.
To adjust traces, I used often “Drag Segments, Keep Slope”.
Recently I started using Vers 5 with “Modern Toolset”.
Trying to adjust Traces, I tryed to use “Drag 45 degree mode”.
Using this, after selecting this mode,
the mousepointer jumps away from the position of the trace,
draging with it the selected trace and as well draging
some other traces.
This has desastrous effects, that makes this mode unusble.
Is it a bug ? or am I doing something wrong ?
As long as this issue is, I will use the “Legacy Toolset”
as a workaround to adjust traces.

Regards
Peter


#2

use interactive drag while in the modern toolset. (shortcut D)


#3

Seems to work the same way to me, (shortcut “D”), but maybe it is my settings.


#4

Yes, shortcut D works fine,
but the menue item “Drag 45 degree mode” is not usable.
IMHO that should be debugged.

Regards


#5

D is shortcut for the context menu item “Drag (45 degree mode)”, they both work for me. What do you mean by “not usable”?


#6

Both work for me, exactly the same way.


#7

By “not usable” I meant that half the layout get draged somewhere else.
Then the only thing I could do, was to break the action,
and revert to before.


#8

The push’n’shove routing works like that. Normally track positions are not critical. When you have, say, 10 tracks, try to route the 11th and have to move those 10 manually, you will think that maybe the 11th could just push those 10 a bit. That’s what push’n’shove does. If you don’t like it, you can try couple of things.

First, if you need one track or via to be in certain place, you can lock it (in Properties).

Second, open the Route->Interactive Router Settings menu. Select “Highlight collisions” mode. Then it won’t push but you will see possible DRC violations.


#9

Ok, I think I see the problem. The modern toolset has a slightly different workflow in the way it works on selected items.

If you use the D shortcut over a segment, the segment is dragged.

But if you right click and then select “Drag…” it works on whatever is currently selected. So if you use the menu, make sure you have the right segment selected.


#10

No,
even if the segment is selected correctly,
the problem is, that the mousepointer is jumping away unintential
while dragging a chaos.


#11

That shouldn’t happen, it should snap to grid points. Be sure to have proper grid selected.


#12

And BTW, now as much as usually a couple of screenshots or, better yet, a screencast, could help us see immediately where the problem is.


#13

If the mousepointer would stay at the position where I did right click
and select "Drag … " until I move the mousepointer myself,
then everything would be ok.
But if I start to move, the mouspointer jumps and causes desaster.


#14

So it works well when you position the mouse over the track and press D, but not when you open the context menu and select the corresponding menu item? If that’s so, it sounds like a bug. What’s your OS and exact KiCad information? Open Help->About KiCad and Copy Version Info and paste it here.


#15

My OS: Ubuntu 18.04.01
KiCad: 5.0.0-fee4fd1~66~ubuntu18.04.01, release build

I tested again in detail:
I move the mouse over the segment.
I do rigtht click. The segment gets highlighted.
And the context menue appears.
I select the "drag … "
The menue disappears.
The mouse pointer is now at the position as before the right click.
Touching the mouse, the mouse pointer first jumps away.
With several different tests, I tried to see where it jumps to:
It is the position on the screen where the mousepointer was in the menue, before the menue disappeared.

Regards


#16

On my system the cursor doesn’t jump. Maybe your grid setting is too big?


#17

This is highly dependent on your window manager under X. Many have options that explicitly forbid warping the cursor. It sounds like this is the case for you. We try to put the cursor back where it was but your window manager may override this.


#18

I thought this was an intended “feature”; that some have complained about.

It happens to be that I like this “feature”; another “quirk” of KiCad that seems to be different but also better.


#19

Now the issue becomes clearer !
I tested the issue again on a different PC with different graphics.
And there it works well.
The PC with the problem is an AMD Kaveri (RADEON).
The different PC with the same OS and same KiCad,
the only difference is that graphics is NVIDEA nForce630a,
an there is no problem.

I think that I will now take this into account for further use.

many thanks for that clarification.


#20

Welcome to the world of Linux on the Desktop :slight_smile: Change your graphics card and the cursor warping stops working. I recently changed to Ubuntu 18.04 LTS and my touchpad scrolling doesn’t work anymore :slight_smile: