Customized Library Directories need jump start


#1

When searching for a footprint f.i. during footprint association on eeschema, and I have started the software recently Kicad correctly complains about libraries not existing at the location as below. Because the libraries aren#t there.

image

I have located my libraries in the following folders as specified in “Preferences/Path Configuration”

image

Interestingly the path variables get set immediately after I click “OK”, (just a click - nothing else) in the above window,. i.e. the error message as shown on top does not appear and Kicad finds the libraries as specified in preferences.
I’ve spend hours trying to find the trick to make Kicad start using the customized directories from the get go to no avail. Can somebody enlighten me.
thanks


#2

The path variables are only used if you setup the lib tables that way.

Look at the library managers in eeschema and pcb_new. The path variables are only used if the paths in there start with ${PATH VARIABLE}.


#3

Thanks Rene,

  I'm sorry to bug you, but I do not make any progress on this

issue.

  When I start the program I get the following read-out in 

pcbnew/Preferences/Footprint Libraries Manager. Obviously KISYSMOD
points to the wrong (empty) directory.

Upon invoking “Preferences/Configure Path” i get the following

  without any input from my side  "Path Configuration" gets the

correct info from somewhere (see line 3) and by simply clicking
here “OK” the path variable gets properly set and I can use the
libraries.

thanks, again for your quick turn-around

Martin


#4

I think in windows it is possible that you have set the path variables in the windows registry. That overwrites the kicad internal settings.

See: New EEschema symbol library management - what a mess!


#5

Thanks for the link, I followed the advise and made changes to
environment variabls via system tools. Some variables were set
correctly some (footprints) not. That explains the behavior as
explained earlier.

  I deleted the KICAD related system variables and that did the

trick.

Thanks much for your help

Martin


#6

It’s good you got the problem solved. As a general remark, the way KiCad and the KiCad Windows installer handles the libraries and the environment variables works nicely for the first time installation, but not necessarily if you try to make changes. For example if you install a newer version of the libraries (from the git repo) to a custom location you have to remember to copy or to create a new *-lib-table and to change the environment variable to point to the new location. And because the Win installer has semi-silently set the environment variables, the old values will override those which you try to set with the KiCad preferences dialog. What KiCad offers is some text in the GUI which most users don’t read anyways and those who read don’t necessarily even know what environment variables are.

Maybe I should widen the scope of my draft document https://docs.google.com/document/d/1Rq8i2Ay7qpGpffaj-AQmE-Xp88ikHhgyt0Ygpi8717o/edit?usp=sharing to cover everything about KiCad environment variables.


#7

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.